summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/pam/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
commit6c619a60fd89b5e75a93cff06977c552ddf1e621 (patch)
tree630ca50ea1c128c4be85ce920ecf034c561bf7fe /abs/core-testing/pam/PKGBUILD
parent0b2b9b97e95f8f8bfda1d1fe09136d121cd0750d (diff)
parent634dff8fdd0a9c866c92f0020f282c23d1a438d8 (diff)
downloadlinhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.zip
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.gz
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core-testing/pam/PKGBUILD')
-rw-r--r--abs/core-testing/pam/PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/abs/core-testing/pam/PKGBUILD b/abs/core-testing/pam/PKGBUILD
index 4bdca6a..0750e52 100644
--- a/abs/core-testing/pam/PKGBUILD
+++ b/abs/core-testing/pam/PKGBUILD
@@ -1,22 +1,23 @@
-# $Id: PKGBUILD 3761 2008-06-30 20:27:30Z andyrtr $
+# $Id: PKGBUILD 17251 2008-10-27 08:14:27Z jgc $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=pam
-pkgver=1.0.1
-pkgrel=11
+pkgver=1.0.2
+pkgrel=2
pkgdesc="PAM (Pluggable Authentication Modules) library"
arch=(i686 x86_64)
license=('GPL2')
url="http://www.kernel.org/pub/linux/libs/pam/"
groups=('base')
depends=('glibc' 'db>=4.7' 'cracklib')
+makedepends=('flex')
backup=(etc/security/{access.conf,group.conf,limits.conf,namespace.conf,namespace.init,pam_env.conf,time.conf} etc/pam.d/other etc/default/passwd etc/environment)
source=(http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2 \
- ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2/pam_unix2-2.1.tar.bz2 \
+ ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2/pam_unix2-2.6.tar.bz2 \
other)
options=('!libtool' '!emptydirs')
-md5sums=('1c75f81bd44c5da93014992820917847'
- '08d3bc1940897b5dfcbe2f51dd979ad0'
- '6e6c8719e5989d976a14610f340bd33a')
+md5sums=('fc5e35645b75befae28c88b711b28ffb'
+ 'e2788389a6c59224110a45fcff30e02b'
+ '6e6c8719e5989d976a14610f340bd33a')
build() {
cd $startdir/src/Linux-PAM-$pkgver
@@ -26,7 +27,7 @@ build() {
install -D -m644 ../other $startdir/pkg/etc/pam.d/other
# build pam_unix2 module
# source ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2
- cd $startdir/src/pam_unix2-2.1
+ cd $startdir/src/pam_unix2-2.6
./configure
make || return 1
make DESTDIR=$startdir/pkg install