summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/perl_modules/perl-javascript/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-04-05 04:49:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-04-05 04:49:01 (GMT)
commit684a7deefc1909d5cea43dd69310acc2565def02 (patch)
treeaad8f0d45aa55772bc3e48ee407af049531a67a6 /abs/core-testing/perl_modules/perl-javascript/PKGBUILD
parentde21519400332f3e15479519d882ac7c1824d1f5 (diff)
downloadlinhes_pkgbuild-684a7deefc1909d5cea43dd69310acc2565def02.zip
linhes_pkgbuild-684a7deefc1909d5cea43dd69310acc2565def02.tar.gz
linhes_pkgbuild-684a7deefc1909d5cea43dd69310acc2565def02.tar.bz2
perl-pathtools: Added
perl-javascript: Added. Needed for Shepherd. REF FS#282
Diffstat (limited to 'abs/core-testing/perl_modules/perl-javascript/PKGBUILD')
-rw-r--r--abs/core-testing/perl_modules/perl-javascript/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/core-testing/perl_modules/perl-javascript/PKGBUILD b/abs/core-testing/perl_modules/perl-javascript/PKGBUILD
new file mode 100644
index 0000000..8ce00cb
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-javascript/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=perl-javascript
+_realname=JavaScript
+pkgver=1.12
+pkgrel=1
+pkgdesc="get name of current working directory"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~KWILLIAMS/Path-Class"
+
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0' spidermonkey)
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/C/CL/CLAESJAC/JavaScript-$pkgver.tar.gz)
+#source=(http://search.cpan.org/CPAN/authors/id/T/TB/TBUSCH/JavaScript-SpiderMonkey-0.19.tar.gz)
+build() {
+ cd $startdir/src/$_realname-$pkgver
+ JS_INC=/usr/include/js PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=$startdir/pkg || return 1
+ find $startdir/pkg -name '.packlist' -delete
+ find $startdir/pkg -name '*.pod' -delete
+}
+