summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/perl_modules/perl-list-moreutils/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-03-22 22:10:53 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-03-22 22:10:53 (GMT)
commitfcc27b022b55e98ef9053c33501b7173fc193d55 (patch)
tree1f57cfc2c0c6a5fbad619175c73dc6c2ebc56112 /abs/core-testing/perl_modules/perl-list-moreutils/PKGBUILD
parentbb605e913399be9c67bd063e49103663033f55e1 (diff)
downloadlinhes_pkgbuild-fcc27b022b55e98ef9053c33501b7173fc193d55.zip
linhes_pkgbuild-fcc27b022b55e98ef9053c33501b7173fc193d55.tar.gz
linhes_pkgbuild-fcc27b022b55e98ef9053c33501b7173fc193d55.tar.bz2
Various modules need for Shepherd.
Diffstat (limited to 'abs/core-testing/perl_modules/perl-list-moreutils/PKGBUILD')
-rw-r--r--abs/core-testing/perl_modules/perl-list-moreutils/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/core-testing/perl_modules/perl-list-moreutils/PKGBUILD b/abs/core-testing/perl_modules/perl-list-moreutils/PKGBUILD
new file mode 100644
index 0000000..a7d80bb
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-list-moreutils/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: François Charette <firmicus ατ gmx δοτ net>
+
+pkgname=perl-list-moreutils
+pkgver=0.22
+pkgrel=1
+pkgdesc="Provide the stuff missing in List::Util"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~VPARSEVAL/List-MoreUtils"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/V/VP/VPARSEVAL/List-MoreUtils-$pkgver.tar.gz)
+md5sums=('3a6ec506f40662ab1296c48c5eb72016')
+
+build() {
+ cd $startdir/src/List-MoreUtils-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=$startdir/pkg || return 1
+ find $startdir/pkg -name '.packlist' -delete
+ find $startdir/pkg -name '*.pod' -delete
+}