summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/php
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-01 03:14:54 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-01 03:14:54 (GMT)
commit7b35632e80f168d8c5f2220bf610ee7e24b81270 (patch)
tree8facf3fa565911f056a08e38f6a5eed0f756f9c6 /abs/core-testing/php
parent7e10f51870aa10be3b35d7912a7b54e30f608bb8 (diff)
parent7accc0f042acdfdca9f067b1d4011d6ac01b1a74 (diff)
downloadlinhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.zip
linhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.tar.gz
linhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core-testing/php')
-rw-r--r--abs/core-testing/php/PKGBUILD10
-rw-r--r--abs/core-testing/php/php.ini2
2 files changed, 8 insertions, 4 deletions
diff --git a/abs/core-testing/php/PKGBUILD b/abs/core-testing/php/PKGBUILD
index b7b99c1..c549d56 100644
--- a/abs/core-testing/php/PKGBUILD
+++ b/abs/core-testing/php/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=php
pkgver=5.2.6
-pkgrel=17
+pkgrel=20
_suhosinver=0.9.6.2
pkgdesc='A high-level scripting language'
arch=('i686' 'x86_64')
@@ -39,10 +39,14 @@ optdepends=('bzip2: bz2' \
'libxslt: xsl' \
)
options=('emptydirs')
-source=("http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2" \
+source=("http://museum.php.net/php5/${pkgname}-${pkgver}.tar.bz2" \
"http://download.suhosin.org/suhosin-patch-${pkgver}-${_suhosinver}.patch.gz" \
'php.ini' 'apache.conf' 'db-configure.patch')
-
+md5sums=('7380ffecebd95c6edb317ef861229ebd'
+ 'f2ec986341a314c271259dbe4d940858'
+ '160b4a4f6fba59e646c3b79e3cb0f134'
+ '96ca078be6729b665be8a865535a97bf'
+ '74e5ce5a02488ec91b1c59f539e42936')
build() {
phpconfig="--prefix=/usr \
diff --git a/abs/core-testing/php/php.ini b/abs/core-testing/php/php.ini
index 0d05055..21c3db1 100644
--- a/abs/core-testing/php/php.ini
+++ b/abs/core-testing/php/php.ini
@@ -249,7 +249,7 @@ safe_mode_protected_env_vars = LD_LIBRARY_PATH
; and below. This directive makes most sense if used in a per-directory
; or per-virtualhost web server configuration file. This directive is
; *NOT* affected by whether Safe Mode is turned On or Off.
-open_basedir = /data/srv/httpd/htdocs/:/home/:/tmp/:/usr/share/pear/:/data/srv/tmp:/usr/share/mythtv/mythweather/scripts/:/data/srv/httpd/htdocs/mythweb/data/video
+open_basedir = /data/srv/httpd/htdocs/:/home/:/tmp/:/usr/share/pear/:/data/srv/tmp:/usr/share/mythtv/mythweather/scripts/:/data/srv/httpd/htdocs/mythweb/data/video:/myth/ipodfeed:/data/srv/httpd/htdocs/archive
; This directive allows you to disable certain functions for security reasons.
; It receives a comma-delimited list of function names. This directive is