summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/python/python-2.6-gdbm.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
commit6c619a60fd89b5e75a93cff06977c552ddf1e621 (patch)
tree630ca50ea1c128c4be85ce920ecf034c561bf7fe /abs/core-testing/python/python-2.6-gdbm.patch
parent0b2b9b97e95f8f8bfda1d1fe09136d121cd0750d (diff)
parent634dff8fdd0a9c866c92f0020f282c23d1a438d8 (diff)
downloadlinhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.zip
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.gz
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core-testing/python/python-2.6-gdbm.patch')
-rw-r--r--abs/core-testing/python/python-2.6-gdbm.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/abs/core-testing/python/python-2.6-gdbm.patch b/abs/core-testing/python/python-2.6-gdbm.patch
new file mode 100644
index 0000000..0f223f6
--- /dev/null
+++ b/abs/core-testing/python/python-2.6-gdbm.patch
@@ -0,0 +1,12 @@
+diff -Naur Python-2.6-old/setup.py Python-2.6/setup.py
+--- Python-2.6-old/setup.py 2008-09-30 10:15:45.000000000 +1000
++++ Python-2.6/setup.py 2008-12-07 16:04:01.000000000 +1000
+@@ -1013,7 +1013,7 @@
+ if self.compiler.find_library_file(lib_dirs, 'ndbm'):
+ ndbm_libs = ['ndbm']
+ else:
+- ndbm_libs = []
++ ndbm_libs = ['gdbm', 'gdbm_compat']
+ exts.append( Extension('dbm', ['dbmmodule.c'],
+ define_macros=[('HAVE_NDBM_H',None)],
+ libraries = ndbm_libs ) )