summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit-scripts
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-11-30 04:11:03 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-11-30 04:11:03 (GMT)
commitf78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f (patch)
tree35b4ab3030640a144537124112e3d65d138672f5 /abs/core-testing/runit-scripts
parentfba7ea15ad46f8655bf17ab4c1cc5a8228d39e1b (diff)
parentf0da28db238a7c58552446e2d87bae48a0f9718b (diff)
downloadlinhes_pkgbuild-f78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f.zip
linhes_pkgbuild-f78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f.tar.gz
linhes_pkgbuild-f78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/runit-scripts')
-rwxr-xr-xabs/core-testing/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/lircd/run11
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/nfsd/run2
3 files changed, 13 insertions, 2 deletions
diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index 17758de..7d68dd4 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=1.8.0
-pkgrel=3
+pkgrel=5
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
index 4457b37..57b1b48 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
@@ -2,6 +2,16 @@
exec 2>&1
run_lircd2=false
. /etc/systemconfig
+
+function dvico_detect {
+
+
+ if [ x$Remotetype = "dvico" ]
+ then
+ DEVICE="/dev/usb/hiddev0"
+ fi
+}
+
function imon_detect {
if [ -e /dev/lirc_imon ]
then
@@ -27,6 +37,7 @@ case $ReceiverType in
DEVICE=`ls /dev/lirc[0-9] 2>/dev/null |sort |sed '/./,$!d'|head -n 1 `
imon_detect
+ dvico_detect
;;
esac
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/nfsd/run b/abs/core-testing/runit-scripts/runitscripts/services/nfsd/run
index 6610fe9..d8435a6 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/nfsd/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/nfsd/run
@@ -5,7 +5,7 @@ exec 2>&1
# (the statd service must ensure portmap is running first)
svwaitup /var/service/nfslock >/dev/null 2>/dev/null
-source /etc/conf.d/nfsd
+source /etc/conf.d/nfs
# Re-export all directories in /etc/exports
/usr/sbin/exportfs -ra > /dev/null 2>/dev/null