summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit/runit.install
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-17 06:41:19 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-17 06:41:19 (GMT)
commit248238844c3d109b3a6cd21eecec5abb4b75a937 (patch)
treeccf1f036b3baef32e21804f899c4dfb66022e33e /abs/core-testing/runit/runit.install
parentfb4e8e768d27649266771a63c1536ee9eeb0e821 (diff)
parent52e7c7e6d99e3d515936d9c51f9fbe65179e5153 (diff)
downloadlinhes_pkgbuild-248238844c3d109b3a6cd21eecec5abb4b75a937.zip
linhes_pkgbuild-248238844c3d109b3a6cd21eecec5abb4b75a937.tar.gz
linhes_pkgbuild-248238844c3d109b3a6cd21eecec5abb4b75a937.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/runit/runit.install')
-rwxr-xr-xabs/core-testing/runit/runit.install12
1 files changed, 10 insertions, 2 deletions
diff --git a/abs/core-testing/runit/runit.install b/abs/core-testing/runit/runit.install
index 977841b..b6fcb07 100755
--- a/abs/core-testing/runit/runit.install
+++ b/abs/core-testing/runit/runit.install
@@ -4,9 +4,10 @@ pre_install () {
if [ ! -f /sbin/halt-init ]
then
mv /sbin/halt /sbin/halt-init
+ mv /sbin/shutdown /sbin/shutdown-init
+fi
rm -f /sbin/reboot
rm -f /sbin/poweroff
-fi
}
@@ -14,9 +15,14 @@ pre_upgrade () {
if [ ! -f /sbin/halt-init ]
then
mv /sbin/halt /sbin/halt-init
+fi
+
+if [ ! -f /sbin/shutdown-init ]
+then
+ mv /sbin/shutdown /sbin/shutdown-init
+fi
rm -f /sbin/reboot
rm -f /sbin/poweroff
-fi
}
@@ -28,6 +34,7 @@ post_install () {
ln -s /sbin/poweroff.script /sbin/poweroff
ln -s /sbin/halt-init /sbin/reboot.init
ln -s /sbin/halt-init /sbin/poweroff.init
+ ln -s /sbin/shutdown.script /sbin/shutdown
}
@@ -41,6 +48,7 @@ post_upgrade(){
ln -s /sbin/poweroff.script /sbin/poweroff
ln -s /sbin/halt-init /sbin/reboot.init
ln -s /sbin/halt-init /sbin/poweroff.init
+ ln -s /sbin/shutdown.script /sbin/shutdown
}