summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit/shutdown.script
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-02-17 17:38:18 (GMT)
committerBob Igo <bob@stormlogic.com>2009-02-17 17:38:18 (GMT)
commit87d276ce0cf6b051d7198adf004ce15590ae294e (patch)
tree507520977c5d6047430f0f9fcd3960dfeaefc022 /abs/core-testing/runit/shutdown.script
parentb1b1890741091e465c5ed2d3bea92f7141b81362 (diff)
parent9d327823ebe603376dce4001876c25149c388c8d (diff)
downloadlinhes_pkgbuild-87d276ce0cf6b051d7198adf004ce15590ae294e.zip
linhes_pkgbuild-87d276ce0cf6b051d7198adf004ce15590ae294e.tar.gz
linhes_pkgbuild-87d276ce0cf6b051d7198adf004ce15590ae294e.tar.bz2
Merge branch 'master' of ssh://igo@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/runit/shutdown.script')
-rwxr-xr-xabs/core-testing/runit/shutdown.script46
1 files changed, 46 insertions, 0 deletions
diff --git a/abs/core-testing/runit/shutdown.script b/abs/core-testing/runit/shutdown.script
new file mode 100755
index 0000000..3bcc5d3
--- /dev/null
+++ b/abs/core-testing/runit/shutdown.script
@@ -0,0 +1,46 @@
+#!/bin/bash
+. /etc/profile
+INIT=`ps -p 1 -o comm=`
+if [ x$INIT = xrunit ]
+then
+ reboot=""
+ halt=""
+ delay=""
+ while getopts rht: name
+ do
+ case $name in
+ r) reboot=1 ;;
+ h) halt=1 ;;
+ t) delay="$OPTARG"
+ if [ x$delay = "xnow" ]
+ then
+ delay=0
+ fi
+ ;;
+ *)
+ exit 2;;
+ esac
+ done
+ if [ x$delay = x ]
+ then
+ echo "-t is mandatory"
+ exit 4
+ fi
+
+ if [ x$reboot = x1 ]
+ then
+ wall "System will reboot in $delay seconds"
+ sleep $delay
+ /sbin/runit-init 6
+ fi
+
+ if [ x$halt = x1 ]
+ then
+ wall "System will poweroff in $delay seconds"
+ sleep $delay
+ /sbin/runit-init 0
+ fi
+
+else
+ /sbin/shutdown-init $@
+fi