summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit/shutdown.script
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-17 06:41:19 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-17 06:41:19 (GMT)
commit248238844c3d109b3a6cd21eecec5abb4b75a937 (patch)
treeccf1f036b3baef32e21804f899c4dfb66022e33e /abs/core-testing/runit/shutdown.script
parentfb4e8e768d27649266771a63c1536ee9eeb0e821 (diff)
parent52e7c7e6d99e3d515936d9c51f9fbe65179e5153 (diff)
downloadlinhes_pkgbuild-248238844c3d109b3a6cd21eecec5abb4b75a937.zip
linhes_pkgbuild-248238844c3d109b3a6cd21eecec5abb4b75a937.tar.gz
linhes_pkgbuild-248238844c3d109b3a6cd21eecec5abb4b75a937.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/runit/shutdown.script')
-rwxr-xr-xabs/core-testing/runit/shutdown.script46
1 files changed, 46 insertions, 0 deletions
diff --git a/abs/core-testing/runit/shutdown.script b/abs/core-testing/runit/shutdown.script
new file mode 100755
index 0000000..3bcc5d3
--- /dev/null
+++ b/abs/core-testing/runit/shutdown.script
@@ -0,0 +1,46 @@
+#!/bin/bash
+. /etc/profile
+INIT=`ps -p 1 -o comm=`
+if [ x$INIT = xrunit ]
+then
+ reboot=""
+ halt=""
+ delay=""
+ while getopts rht: name
+ do
+ case $name in
+ r) reboot=1 ;;
+ h) halt=1 ;;
+ t) delay="$OPTARG"
+ if [ x$delay = "xnow" ]
+ then
+ delay=0
+ fi
+ ;;
+ *)
+ exit 2;;
+ esac
+ done
+ if [ x$delay = x ]
+ then
+ echo "-t is mandatory"
+ exit 4
+ fi
+
+ if [ x$reboot = x1 ]
+ then
+ wall "System will reboot in $delay seconds"
+ sleep $delay
+ /sbin/runit-init 6
+ fi
+
+ if [ x$halt = x1 ]
+ then
+ wall "System will poweroff in $delay seconds"
+ sleep $delay
+ /sbin/runit-init 0
+ fi
+
+else
+ /sbin/shutdown-init $@
+fi