summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/sqlite3/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/sqlite3/PKGBUILD
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/sqlite3/PKGBUILD')
-rw-r--r--abs/core-testing/sqlite3/PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/abs/core-testing/sqlite3/PKGBUILD b/abs/core-testing/sqlite3/PKGBUILD
index acf7a94..0a6fc93 100644
--- a/abs/core-testing/sqlite3/PKGBUILD
+++ b/abs/core-testing/sqlite3/PKGBUILD
@@ -1,23 +1,23 @@
-# $Id: PKGBUILD 22976 2008-12-30 11:35:01Z andyrtr $
+# $Id: PKGBUILD 86812 2010-08-04 21:15:20Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=sqlite3
-pkgver=3.6.10
-pkgrel=5
+pkgver=3.7.0.1
+pkgrel=1
pkgdesc="A C library that implements an SQL database engine"
arch=('i686' 'x86_64')
license=('custom')
url="http://www.sqlite.org/"
-depends=('readline')
+depends=('readline>=6.0.00')
makedepends=('tcl')
conflicts=('sqlite')
replaces=('sqlite')
source=(http://www.sqlite.org/sqlite-$pkgver.tar.gz
license.txt)
-md5sums=('a03bdc86df4025b6881d58557e4b5bd3'
- 'c1cdbc5544034d9012e421e75a5e4890')
options=(!libtool)
+md5sums=('d25d7551ba6bb310362cb0e7d4906f25'
+ 'c1cdbc5544034d9012e421e75a5e4890')
build() {
cd ${srcdir}/sqlite-${pkgver}
@@ -25,8 +25,15 @@ build() {
export CFLAGS="$CFLAGS -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_COLUMN_METADATA=1"
./configure --prefix=/usr \
--enable-threadsafe \
+ --enable-threads-override-locks \
+ --enable-cross-thread-connections \
--disable-static \
--enable-load-extension || return 1
+
+ # rpath removal
+ sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+
make || return 1
make DESTDIR=${pkgdir} install || return 1
install -Dm0644 sqlite3.1 ${pkgdir}/usr/share/man/man1/sqlite3.1