summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/sqlite3/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-23 01:40:37 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-23 01:40:37 (GMT)
commit7f24a313f0815854ff88a0e33a066a73de4f3be1 (patch)
tree63f1de317bd6d4d3b283939c3481c3ed3e4e71f9 /abs/core-testing/sqlite3/PKGBUILD
parentde2ffe85032410437eb7dabdec63031e908fd43c (diff)
downloadlinhes_pkgbuild-7f24a313f0815854ff88a0e33a066a73de4f3be1.zip
linhes_pkgbuild-7f24a313f0815854ff88a0e33a066a73de4f3be1.tar.gz
linhes_pkgbuild-7f24a313f0815854ff88a0e33a066a73de4f3be1.tar.bz2
initial checkin of lighttpd and supporting libs.
Also included is a new package callede local-website. This package contains the contents of http://localhost that runs on every LinHES box. The initial checkin is taken from R5.5
Diffstat (limited to 'abs/core-testing/sqlite3/PKGBUILD')
-rw-r--r--abs/core-testing/sqlite3/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/core-testing/sqlite3/PKGBUILD b/abs/core-testing/sqlite3/PKGBUILD
new file mode 100644
index 0000000..eb1dbc6
--- /dev/null
+++ b/abs/core-testing/sqlite3/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 12988 2008-09-25 16:26:35Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=sqlite3
+pkgver=3.6.3
+pkgrel=1
+pkgdesc="A C library that implements an SQL database engine"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.sqlite.org/"
+depends=('readline')
+makedepends=('tcl')
+conflicts=('sqlite')
+replaces=('sqlite')
+source=(http://www.sqlite.org/sqlite-$pkgver.tar.gz
+ sqlite-3.5.8-pkgconfig-version.patch
+ license.txt)
+options=(!libtool)
+md5sums=('671d2715f33158abc47a7a2ddd6066c5'
+ '025965a176173eaf21877f6daed088d4'
+ 'c1cdbc5544034d9012e421e75a5e4890')
+
+build() {
+ cd ${srcdir}/sqlite-${pkgver}
+ patch -Np1 -i ${srcdir}/sqlite-3.5.8-pkgconfig-version.patch || return 1
+ ./configure --prefix=/usr --enable-threadsafe --disable-static || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install
+ install -Dm0644 sqlite3.1 ${pkgdir}/usr/share/man/man1/sqlite3.1
+
+ # license
+ install -Dm644 ${srcdir}/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
+}