summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/vdpauinfo-legacy
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2010-04-18 05:55:06 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2010-04-18 05:55:06 (GMT)
commitd4589eee8998a168eaa79af7a04d82faac1a738d (patch)
tree731625204f3902bb9b5f7a8a492c6b8fcc09c915 /abs/core-testing/vdpauinfo-legacy
parent5106977528d3d26919263bf62d504035a7720633 (diff)
parent787f13cd63c75c9c5090c10c0e888f48a59c0e49 (diff)
downloadlinhes_pkgbuild-d4589eee8998a168eaa79af7a04d82faac1a738d.zip
linhes_pkgbuild-d4589eee8998a168eaa79af7a04d82faac1a738d.tar.gz
linhes_pkgbuild-d4589eee8998a168eaa79af7a04d82faac1a738d.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/vdpauinfo-legacy')
-rw-r--r--abs/core-testing/vdpauinfo-legacy/PKGBUILD26
-rwxr-xr-xabs/core-testing/vdpauinfo-legacy/vdpauinfo2
2 files changed, 28 insertions, 0 deletions
diff --git a/abs/core-testing/vdpauinfo-legacy/PKGBUILD b/abs/core-testing/vdpauinfo-legacy/PKGBUILD
new file mode 100644
index 0000000..7e7fe26
--- /dev/null
+++ b/abs/core-testing/vdpauinfo-legacy/PKGBUILD
@@ -0,0 +1,26 @@
+# It is not expected that vdpau will work with the 71xx nVidia drivers, but we still want
+# 'vdpinfo' to return something when users run it, even if the real 'vdpinfo' won't build
+# for their nVidia driver version.
+
+pkgname=vdpauinfo-legacy
+pkgver=1
+pkgrel=4
+pkgdesc="tells the user they can't handle vdpau"
+license=('GPLv2')
+arch=('i686' 'x86_64')
+depends=('')
+# Just let the dependency on the right nvidia and nvidia-utils versions
+# handle conflicts via those packages conflicts.
+conflicts=(vdpauinfo)
+provides=('vpinfo' 'vdpauinfo')
+source=(vdpauinfo)
+md5sums=()
+
+build() {
+ LH_ROOT=/usr/LH
+ mkdir -p $startdir/pkg/$LH_ROOT/bin/
+
+ cd $startdir
+ install -m0755 -D vdpauinfo $startdir/pkg/$LH_ROOT/bin/
+}
+md5sums=('502f0a21bd1232e5a6bccb17cd63116d')
diff --git a/abs/core-testing/vdpauinfo-legacy/vdpauinfo b/abs/core-testing/vdpauinfo-legacy/vdpauinfo
new file mode 100755
index 0000000..9b237dc
--- /dev/null
+++ b/abs/core-testing/vdpauinfo-legacy/vdpauinfo
@@ -0,0 +1,2 @@
+#!/bin/bash
+echo "vdpau is unsupported"