summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/wget
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-10 01:46:12 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-10 01:46:12 (GMT)
commit690fa2bf80dba5e7576234094575bef0475e1f74 (patch)
tree30cd9ea13b960918d962e6e921a1792b4c476c0d /abs/core-testing/wget
parent525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (diff)
downloadlinhes_pkgbuild-690fa2bf80dba5e7576234094575bef0475e1f74.zip
linhes_pkgbuild-690fa2bf80dba5e7576234094575bef0475e1f74.tar.gz
linhes_pkgbuild-690fa2bf80dba5e7576234094575bef0475e1f74.tar.bz2
pacman & helpers: update pacman to lastest version from archlinux
Diffstat (limited to 'abs/core-testing/wget')
-rw-r--r--abs/core-testing/wget/PKGBUILD20
l---------abs/core-testing/wget/wget-1.12-2-i686.pkg.tar.gz1
-rw-r--r--abs/core-testing/wget/wget.install20
3 files changed, 35 insertions, 6 deletions
diff --git a/abs/core-testing/wget/PKGBUILD b/abs/core-testing/wget/PKGBUILD
index 5a9e0cb..1ef6911 100644
--- a/abs/core-testing/wget/PKGBUILD
+++ b/abs/core-testing/wget/PKGBUILD
@@ -1,21 +1,29 @@
-# $Id: PKGBUILD 4756 2008-07-09 20:00:54Z andyrtr $
-# Maintainer: Judd Vinet <jvinet@zeroflux.org>
+# $Id: PKGBUILD 75183 2010-04-01 01:40:17Z pierre $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
pkgname=wget
-pkgver=1.11.4
-pkgrel=10
+pkgver=1.12
+pkgrel=2
pkgdesc="A network utility to retrieve files from the Web"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://www.gnu.org/software/wget/wget.html"
license=('GPL3')
groups=('base')
depends=('glibc' 'openssl')
+optdepends=('ca-certificates: HTTPS downloads')
backup=('etc/wgetrc')
+install=wget.install
source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('69e8a7296c0e12c53bd9ffd786462e87')
+md5sums=('141461b9c04e454dc8933c9d1f2abf83')
build() {
cd ${srcdir}/$pkgname-$pkgver
./configure --prefix=/usr --sysconfdir=/etc
make || return 1
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
make DESTDIR=${pkgdir} install
}
diff --git a/abs/core-testing/wget/wget-1.12-2-i686.pkg.tar.gz b/abs/core-testing/wget/wget-1.12-2-i686.pkg.tar.gz
new file mode 120000
index 0000000..6fc2266
--- /dev/null
+++ b/abs/core-testing/wget/wget-1.12-2-i686.pkg.tar.gz
@@ -0,0 +1 @@
+/data/pkg_repo/packages/wget-1.12-2-i686.pkg.tar.gz \ No newline at end of file
diff --git a/abs/core-testing/wget/wget.install b/abs/core-testing/wget/wget.install
new file mode 100644
index 0000000..1715333
--- /dev/null
+++ b/abs/core-testing/wget/wget.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(wget.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}