summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/which/which.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-02-11 23:07:10 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-02-11 23:07:10 (GMT)
commit5e703a85e3eadcfbcf914ac00d9fe44bf55b895f (patch)
treeec5d706c4245fb4c697a2da0cd42298fc3ff8746 /abs/core-testing/which/which.install
parent9cd74e0da2e38769e236340857b487a2bc329904 (diff)
parent174779d894316a9eb9c1b8edc7e0b228328934ed (diff)
downloadlinhes_pkgbuild-5e703a85e3eadcfbcf914ac00d9fe44bf55b895f.zip
linhes_pkgbuild-5e703a85e3eadcfbcf914ac00d9fe44bf55b895f.tar.gz
linhes_pkgbuild-5e703a85e3eadcfbcf914ac00d9fe44bf55b895f.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/core-testing/which/which.install')
-rw-r--r--abs/core-testing/which/which.install20
1 files changed, 20 insertions, 0 deletions
diff --git a/abs/core-testing/which/which.install b/abs/core-testing/which/which.install
new file mode 100644
index 0000000..899bd6f
--- /dev/null
+++ b/abs/core-testing/which/which.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(which.info)
+
+post_install() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+# vim:set ts=2 sw=2 et: