summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/wlan-ng26-utils-svn/tmp/trunk/scripts/Makefile
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 03:16:13 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 03:16:13 (GMT)
commitee26e87efd151e56a9eb8142fdec6d2e5d9c733c (patch)
treec2f787f41517e60e879fa14071e43104dc08a507 /abs/core-testing/wlan-ng26-utils-svn/tmp/trunk/scripts/Makefile
parent1d374402a7edf5c8c3e3351641223998553e77c3 (diff)
downloadlinhes_pkgbuild-ee26e87efd151e56a9eb8142fdec6d2e5d9c733c.zip
linhes_pkgbuild-ee26e87efd151e56a9eb8142fdec6d2e5d9c733c.tar.gz
linhes_pkgbuild-ee26e87efd151e56a9eb8142fdec6d2e5d9c733c.tar.bz2
Rename wlan-ng26-utils to wlan-ng26-utils-svn
Diffstat (limited to 'abs/core-testing/wlan-ng26-utils-svn/tmp/trunk/scripts/Makefile')
-rw-r--r--abs/core-testing/wlan-ng26-utils-svn/tmp/trunk/scripts/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/core-testing/wlan-ng26-utils-svn/tmp/trunk/scripts/Makefile b/abs/core-testing/wlan-ng26-utils-svn/tmp/trunk/scripts/Makefile
new file mode 100644
index 0000000..7f37e49
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils-svn/tmp/trunk/scripts/Makefile
@@ -0,0 +1,36 @@
+CURR_DIR :=$(shell pwd)
+
+export CURR_DIR
+
+.PHONY: get_version
+
+all: clean get_version get_options
+
+get_version:
+ @if [ ! -d $(KERNEL_SOURCE)/ ]; then \
+ echo "";\
+ echo "$(KERNEL_SOURCE) directory does not exist. Please edit the file 'config'";\
+ echo "in this directory and set KERNEL_SOURCE to the correct location of your ";\
+ echo "kernel source.";\
+ echo "";\
+ echo "You are currently running kernel version `uname -r`, the source code should";\
+ echo "be for this version.";\
+ echo "";\
+ exit 1;\
+ fi
+ @if [ ! -f $(KERNEL_SOURCE)/include/linux/version.h ]; then \
+ echo "$(KERNEL_SOURCE)/include/linux/version.h is missing. Please run make config";\
+ echo "in your kernel source tree";\
+ exit 1;\
+ fi
+
+ $(CC) -I$(KERNEL_SOURCE)/include get_version.c -o get_version
+
+get_options:
+ $(MAKE) -f $(CURR_DIR)/Makefile.get_options -C $(KERNEL_SOURCE) get_version_target
+
+clean:
+ $(RM) get_version make.opts
+
+distclean: clean
+