summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/wlan-ng26-utils/tmp/trunk/scripts/.svn/text-base/Makefile.svn-base
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-07 09:44:40 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-07 09:44:40 (GMT)
commit22cb9c31cde8a125c3b7d159d8b50941cb5c7714 (patch)
treeffdf1f5463d1c6fcc968ef15a82837210fba0a39 /abs/core-testing/wlan-ng26-utils/tmp/trunk/scripts/.svn/text-base/Makefile.svn-base
parentf018045129450cc43d0e86eedcdd7b43d53ff691 (diff)
downloadlinhes_pkgbuild-22cb9c31cde8a125c3b7d159d8b50941cb5c7714.zip
linhes_pkgbuild-22cb9c31cde8a125c3b7d159d8b50941cb5c7714.tar.gz
linhes_pkgbuild-22cb9c31cde8a125c3b7d159d8b50941cb5c7714.tar.bz2
Updated kernel to 2.6.27. Updated latest PKGBUILD for various packages and recompiled.
Diffstat (limited to 'abs/core-testing/wlan-ng26-utils/tmp/trunk/scripts/.svn/text-base/Makefile.svn-base')
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/scripts/.svn/text-base/Makefile.svn-base36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/scripts/.svn/text-base/Makefile.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/scripts/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..7f37e49
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/scripts/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,36 @@
+CURR_DIR :=$(shell pwd)
+
+export CURR_DIR
+
+.PHONY: get_version
+
+all: clean get_version get_options
+
+get_version:
+ @if [ ! -d $(KERNEL_SOURCE)/ ]; then \
+ echo "";\
+ echo "$(KERNEL_SOURCE) directory does not exist. Please edit the file 'config'";\
+ echo "in this directory and set KERNEL_SOURCE to the correct location of your ";\
+ echo "kernel source.";\
+ echo "";\
+ echo "You are currently running kernel version `uname -r`, the source code should";\
+ echo "be for this version.";\
+ echo "";\
+ exit 1;\
+ fi
+ @if [ ! -f $(KERNEL_SOURCE)/include/linux/version.h ]; then \
+ echo "$(KERNEL_SOURCE)/include/linux/version.h is missing. Please run make config";\
+ echo "in your kernel source tree";\
+ exit 1;\
+ fi
+
+ $(CC) -I$(KERNEL_SOURCE)/include get_version.c -o get_version
+
+get_options:
+ $(MAKE) -f $(CURR_DIR)/Makefile.get_options -C $(KERNEL_SOURCE) get_version_target
+
+clean:
+ $(RM) get_version make.opts
+
+distclean: clean
+