summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/wpa_supplicant/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/wpa_supplicant/PKGBUILD
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/wpa_supplicant/PKGBUILD')
-rw-r--r--abs/core-testing/wpa_supplicant/PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/abs/core-testing/wpa_supplicant/PKGBUILD b/abs/core-testing/wpa_supplicant/PKGBUILD
index 3ecc4a8..0e709fb 100644
--- a/abs/core-testing/wpa_supplicant/PKGBUILD
+++ b/abs/core-testing/wpa_supplicant/PKGBUILD
@@ -1,13 +1,12 @@
-# $Id: PKGBUILD 32196 2009-03-29 14:55:53Z thomas $
+# $Id: PKGBUILD 75193 2010-04-01 02:03:01Z pierre $
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgname=wpa_supplicant
-pkgver=0.6.9
-#_madwifi_ver=0.9.4
-pkgrel=1
+pkgver=0.6.10
+pkgrel=2
pkgdesc="A utility providing key negotiation for WPA wireless networks"
arch=('i686' 'x86_64')
-depends=('openssl' 'dbus-core>=1.2.4' 'readline' 'libnl')
+depends=('openssl' 'dbus-core>=1.2.4' 'readline>=6.0' 'libnl')
optdepends=('wpa_supplicant_gui: wpa_gui program')
license=('GPL')
groups=('base')
@@ -15,18 +14,18 @@ backup=('etc/wpa_supplicant.conf')
url="http://hostap.epitest.fi/wpa_supplicant"
source=(http://hostap.epitest.fi/releases/wpa_supplicant-$pkgver.tar.gz
config)
- #http://downloads.sourceforge.net/sourceforge/madwifi/madwifi-${_madwifi_ver}.tar.gz)
-md5sums=('0efb8fcedf0a8acf6f423dfdb0658fdd'
- 'd472554904cca44e1090e25dea7b03c9')
- #'399d20de8d855a59f20058857c2178ad')
+md5sums=('8985b1030d753e5f74f8acfc34e591bb'
+ '6577abc7060ed2d45dba14bf8934e850')
build() {
- cd "${srcdir}"
- #mv madwifi-${_madwifi_ver} madwifi
cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
cp ${srcdir}/config ./.config
sed -i 's@/usr/local@$(PREFIX)@g' Makefile
make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
make PREFIX=/usr DESTDIR="${pkgdir}" install || return 1
install -m755 -d "${pkgdir}/etc"
install -m644 wpa_supplicant.conf "${pkgdir}/etc/wpa_supplicant.conf" || return 1