summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/xine-lib/ffmpeg_xine.patch
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-02 08:52:13 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-02 08:52:13 (GMT)
commite649efa24662af962e6cbd7b9ece1bdd8f6a9340 (patch)
treed4d46580d6cc8c28ed801f250f73f9cc3b109a1c /abs/core-testing/xine-lib/ffmpeg_xine.patch
parent90d20be43404c4986dc7285cc1dd3ab5f00918e4 (diff)
downloadlinhes_pkgbuild-e649efa24662af962e6cbd7b9ece1bdd8f6a9340.zip
linhes_pkgbuild-e649efa24662af962e6cbd7b9ece1bdd8f6a9340.tar.gz
linhes_pkgbuild-e649efa24662af962e6cbd7b9ece1bdd8f6a9340.tar.bz2
PKGBUILDs needed for Xine and Miro.
Diffstat (limited to 'abs/core-testing/xine-lib/ffmpeg_xine.patch')
-rw-r--r--abs/core-testing/xine-lib/ffmpeg_xine.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/core-testing/xine-lib/ffmpeg_xine.patch b/abs/core-testing/xine-lib/ffmpeg_xine.patch
new file mode 100644
index 0000000..c1d7eb9
--- /dev/null
+++ b/abs/core-testing/xine-lib/ffmpeg_xine.patch
@@ -0,0 +1,39 @@
+diff -ruaN src/combined/ffmpeg.orig/ff_audio_decoder.c src/combined/ffmpeg/ff_audio_decoder.c
+--- src/combined/ffmpeg.orig/ff_audio_decoder.c 2008-12-02 08:30:44.000000000 +0000
++++ src/combined/ffmpeg/ff_audio_decoder.c 2008-12-02 08:38:30.000000000 +0000
+@@ -269,7 +269,7 @@
+ * bits/sample for some codecs (e.g. MS ADPCM) */
+ this->audio_bits = 16;
+
+- this->context->bits_per_sample = this->audio_bits;
++ this->context->bits_per_coded_sample = this->audio_bits;
+ this->context->sample_rate = this->audio_sample_rate;
+ this->context->channels = this->audio_channels;
+ this->context->codec_id = this->codec->id;
+@@ -322,12 +322,12 @@
+
+ if (!this->output_open) {
+ if (!this->audio_bits || !this->audio_sample_rate || !this->audio_channels) {
+- avcodec_decode_audio (this->context,
++ avcodec_decode_audio2 (this->context,
+ (int16_t *)this->decode_buffer,
+ &decode_buffer_size,
+ &this->buf[0],
+ this->size);
+- this->audio_bits = this->context->bits_per_sample;
++ this->audio_bits = this->context->bits_per_coded_sample;
+ this->audio_sample_rate = this->context->sample_rate;
+ this->audio_channels = this->context->channels;
+ if (!this->audio_bits || !this->audio_sample_rate || !this->audio_channels)
+diff -ruaN src/combined/ffmpeg.orig/ff_video_decoder.c src/combined/ffmpeg/ff_video_decoder.c
+--- src/combined/ffmpeg.orig/ff_video_decoder.c 2008-12-02 08:33:53.000000000 +0000
++++ src/combined/ffmpeg/ff_video_decoder.c 2008-12-02 08:38:30.000000000 +0000
+@@ -939,7 +939,7 @@
+ this->context->extradata_size);
+ }
+
+- this->context->bits_per_sample = this->bih.biBitCount;
++ this->context->bits_per_coded_sample = this->bih.biBitCount;
+
+ } else {
+