summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/xine-lib/xine-imagemagick.patch
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-02 08:52:13 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-02 08:52:13 (GMT)
commite649efa24662af962e6cbd7b9ece1bdd8f6a9340 (patch)
treed4d46580d6cc8c28ed801f250f73f9cc3b109a1c /abs/core-testing/xine-lib/xine-imagemagick.patch
parent90d20be43404c4986dc7285cc1dd3ab5f00918e4 (diff)
downloadlinhes_pkgbuild-e649efa24662af962e6cbd7b9ece1bdd8f6a9340.zip
linhes_pkgbuild-e649efa24662af962e6cbd7b9ece1bdd8f6a9340.tar.gz
linhes_pkgbuild-e649efa24662af962e6cbd7b9ece1bdd8f6a9340.tar.bz2
PKGBUILDs needed for Xine and Miro.
Diffstat (limited to 'abs/core-testing/xine-lib/xine-imagemagick.patch')
-rw-r--r--abs/core-testing/xine-lib/xine-imagemagick.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/abs/core-testing/xine-lib/xine-imagemagick.patch b/abs/core-testing/xine-lib/xine-imagemagick.patch
new file mode 100644
index 0000000..9faa4ab
--- /dev/null
+++ b/abs/core-testing/xine-lib/xine-imagemagick.patch
@@ -0,0 +1,11 @@
+--- xine-lib-1.1.15.orig/src/libxinevdec/image.c
++++ xine-lib-1.1.15/src/libxinevdec/image.c
+@@ -110,7 +110,7 @@
+ width = MagickGetImageWidth(wand) & ~1; /* must be even for init_yuv_planes */
+ height = MagickGetImageHeight(wand);
+ img_buf = malloc(width * height * 3);
+- MagickGetImagePixels(wand, 0, 0, width, height, "RGB", CharPixel, img_buf);
++ MagickGetAuthenticPixels(wand, 0, 0, width, height, "RGB", CharPixel, img_buf);
+ DestroyMagickWand(wand);
+
+ _x_stream_info_set(this->stream, XINE_STREAM_INFO_VIDEO_WIDTH, width);