summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-02-19 16:04:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-02-19 16:04:38 (GMT)
commit097ebc5aece43798e785d620d3ad56f568501a2b (patch)
tree364510c7db1d5cde85de51a47f012e414c29cb9f /abs/core-testing
parent31352df953653df1b5d6f193c3ed192536467b31 (diff)
parentac3eb72b60881ff3478663ec4aaf60b708edd870 (diff)
downloadlinhes_pkgbuild-097ebc5aece43798e785d620d3ad56f568501a2b.zip
linhes_pkgbuild-097ebc5aece43798e785d620d3ad56f568501a2b.tar.gz
linhes_pkgbuild-097ebc5aece43798e785d620d3ad56f568501a2b.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/libraw1394/PKGBUILD3
-rw-r--r--abs/core-testing/libraw1394/libraw1394.install18
-rw-r--r--abs/core-testing/mythtv/stable/mythtv/PKGBUILD4
-rwxr-xr-xabs/core-testing/mythtv/trunk/mythtv/PKGBUILD6
4 files changed, 25 insertions, 6 deletions
diff --git a/abs/core-testing/libraw1394/PKGBUILD b/abs/core-testing/libraw1394/PKGBUILD
index 4c73a58..b1065fd 100644
--- a/abs/core-testing/libraw1394/PKGBUILD
+++ b/abs/core-testing/libraw1394/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libraw1394
pkgver=2.0.2
-pkgrel=1
+pkgrel=3
arch=('i686' 'x86_64')
license=('LGPL')
pkgdesc="Provides an API to the Linux IEEE1394 (FireWire) driver"
@@ -12,6 +12,7 @@ depends=('glibc')
makedepends=('pkgconfig')
url="http://www.linux1394.org/"
options=(!libtool force)
+install=libraw1394.install
source=(http://www.linux1394.org/dl/${pkgname}-${pkgver}.tar.gz)
md5sums=('9fbbef5ea31101c4c28085db134fd448')
diff --git a/abs/core-testing/libraw1394/libraw1394.install b/abs/core-testing/libraw1394/libraw1394.install
new file mode 100644
index 0000000..33fb64c
--- /dev/null
+++ b/abs/core-testing/libraw1394/libraw1394.install
@@ -0,0 +1,18 @@
+# arg 1: the new package version
+post_install() {
+ ln -s /usr/lib/libraw1394.so.11.0.1 /usr/lib/libraw1394.so.8
+}
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ rm -fr /usr/lib/libraw1394.so.8
+}
+
+op=$1
+shift
+$op $*
diff --git a/abs/core-testing/mythtv/stable/mythtv/PKGBUILD b/abs/core-testing/mythtv/stable/mythtv/PKGBUILD
index 941452f..7b9c2a4 100644
--- a/abs/core-testing/mythtv/stable/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythtv
pkgver=0.21
-pkgrel=39
+pkgrel=40
pkgdesc="A Homebrew PVR project"
arch=('i686' 'x86_64')
depends=('bash' 'mysql-clients>=5.0' 'qt3' 'lame' 'lirc-utils' 'ffmpeg' \
@@ -39,7 +39,7 @@ build() {
./configure --prefix=/usr --cpu=${ARCH} --enable-mmx --enable-audio-oss \
--enable-audio-alsa --enable-dvb --enable-lirc --enable-joystick-menu \
- --disable-firewire --enable-v4l --enable-ivtv --enable-dvb \
+ --enable-firewire --enable-v4l --enable-ivtv --enable-dvb \
--dvb-path=/usr/include --enable-xvmc --disable-ffmpeg \
--enable-xvmc-pro --enable-xvmc-vld --enable-opengl-vsync \
--disable-audio-jack --disable-audio-arts --disable-directfb || return 1
diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index 4c03923..7299836 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythtv-svn
pkgver=20018
-pkgrel=1
+pkgrel=2
pkgdesc="A personal video recorder for Linux"
url="http://www.mythtv.org"
license="GPL"
@@ -15,7 +15,7 @@ groups=('pvr')
#MAKEFLAGS="-j6"
install='mythtv.install'
-patchs=('smolt_jump.patch' 'DeviceReadBuffer-polltimeout.2.patch' 'hdpvr_audio_codec_selection-v1.1.diff')
+patchs=('smolt_jump.patch' 'hdpvr_audio_codec_selection-v1.1.diff')
#patchs=('svn_main_menu_popup.patch' 'smolt_jump.patch' 'DeviceReadBuffer-polltimeout.2.patch' 'hdpvr_audio_codec_selection-v1.1.diff')
source=('mythbackend' 'myth.sh' `echo ${patchs[@]:0}` )
arch=('i686' 'x86_64')
@@ -48,7 +48,7 @@ build() {
# configure
./configure --prefix=/usr --cpu=${ARCH} \
--enable-vdpau --enable-xvmc --enable-xvmc-pro \
- --enable-opengl-vsync --enable-libfaad --enable-dvb --disable-firewire \
+ --enable-opengl-vsync --enable-libfaad --enable-dvb --enable-firewire \
--compile-type=release --with-bindings=perl,python \
--enable-audio-alsa --disable-audio-jack --disable-audio-arts || return 1