summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
commit116edc0c0cc1b926acce635a76d102408b118a92 (patch)
tree237e661dc7f5b1bb4b18350ab3a48e5a15283851 /abs/core-testing
parent29e945b91760568116a21e0076fae046b33a2663 (diff)
parent7f42f55d022dc8ca818a76dccfc66fce7c8dea4f (diff)
downloadlinhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.zip
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.gz
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/glib2/PKGBUILD24
-rw-r--r--abs/core-testing/mythtv/stable/mythmusic/PKGBUILD7
-rw-r--r--abs/core-testing/pcre/ChangeLog6
-rw-r--r--abs/core-testing/pcre/PKGBUILD18
-rw-r--r--abs/core-testing/php/PKGBUILD2
-rw-r--r--abs/core-testing/php/php.ini2
6 files changed, 31 insertions, 28 deletions
diff --git a/abs/core-testing/glib2/PKGBUILD b/abs/core-testing/glib2/PKGBUILD
index 3e4abd7..f8696a4 100644
--- a/abs/core-testing/glib2/PKGBUILD
+++ b/abs/core-testing/glib2/PKGBUILD
@@ -1,32 +1,30 @@
-# $Id: PKGBUILD 7524 2008-08-02 20:27:35Z jgc $
+# $Id: PKGBUILD 19622 2008-11-28 19:19:41Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=glib2
-pkgver=2.16.5
+pkgver=2.18.3
pkgrel=1
pkgdesc="Common C routines used by GTK+ 2.4 and other libs"
url="http://www.gtk.org/"
arch=(i686 x86_64)
license=('LGPL')
-depends=('pcre>=7.7')
+depends=('pcre>=7.8')
makedepends=('pkgconfig')
-options=('!libtool')
-source=(http://ftp.gnome.org/pub/GNOME/sources/glib/2.16/glib-${pkgver}.tar.bz2
- gkeyfile-bool-nocase.patch
+options=('!libtool' '!docs')
+source=(http://ftp.gnome.org/pub/GNOME/sources/glib/2.18/glib-${pkgver}.tar.bz2
glib2.sh
glib2.csh)
-md5sums=('039f02d47d4071322a3f00abf031e5d9'
- '5ca65611e824662146369e814d49ad06'
+md5sums=('f13996a7bd57525d796a6593f26a7771'
'803017b365bd35dc20b092ce43b8c8c5'
'90c7b830bef4baf225c2eb8b7ead0cab')
build() {
- cd ${startdir}/src/glib-${pkgver}
- patch -Np0 -i ${startdir}/src/gkeyfile-bool-nocase.patch || return 1
+ cd "${srcdir}/glib-${pkgver}"
./configure --prefix=/usr --enable-static --enable-shared --with-pcre=system --disable-fam || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ make DESTDIR="${pkgdir}" install || return 1
- install -d -m755 ${startdir}/pkg/etc/profile.d
- install -m755 ${startdir}/src/glib2.{csh,sh} ${startdir}/pkg/etc/profile.d/ || return 1
+ install -d -m755 "${pkgdir}/etc/profile.d"
+ install -m755 "${srcdir}/glib2.sh" "${pkgdir}/etc/profile.d/" || return 1
+ install -m755 "${srcdir}/glib2.csh" "${pkgdir}/etc/profile.d/" || return 1
}
diff --git a/abs/core-testing/mythtv/stable/mythmusic/PKGBUILD b/abs/core-testing/mythtv/stable/mythmusic/PKGBUILD
index 02adcce..fbbfbc4 100644
--- a/abs/core-testing/mythtv/stable/mythmusic/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythmusic/PKGBUILD
@@ -4,13 +4,14 @@
pkgname=mythmusic
pkgver=0.21
-pkgrel=2
+pkgrel=5
pkgdesc="Music playing plugin for MythTV"
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
license=('GPL')
depends=("mythtv>=${pkgver}" 'libid3tag' 'libmad' 'libvorbis' 'flac>=1.1.4' 'libcdaudio' \
- 'cdparanoia' 'fftw2' 'sdl' 'faad2>=2.6.1' 'lame' 'taglib')
+ 'cdparanoia' 'fftw2' 'sdl' 'faad2>=2.6.1' 'lame' 'taglib' \
+ 'libvisual-plugins' 'libvisual-projectm')
source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
md5sums=('af20a78ac66719feddf9a39f1a799ded')
groups=('mythtv-extras')
@@ -22,7 +23,7 @@ build() {
# use QT3 qmake
export PATH=$QTDIR/bin:$PATH
./configure --prefix=/usr --disable-all --enable-mythmusic --enable-fftw \
- --enable-sdl --enable-aac --enable-opengl
+ --enable-sdl --enable-aac --enable-opengl --enable-libvisual
qmake mythplugins.pro
make qmake || return 1
diff --git a/abs/core-testing/pcre/ChangeLog b/abs/core-testing/pcre/ChangeLog
index fa86646..a1850cf 100644
--- a/abs/core-testing/pcre/ChangeLog
+++ b/abs/core-testing/pcre/ChangeLog
@@ -1,3 +1,9 @@
+2008-09-05 Eric Belanger <eric@archlinux.org>
+
+ * pcre 7.8-1
+ * Upstream update
+ * Fixed license
+
2008-07-07 Eric Belanger <eric@archlinux.org>
* pcre 7.7-2
diff --git a/abs/core-testing/pcre/PKGBUILD b/abs/core-testing/pcre/PKGBUILD
index 2cf7252..b019bed 100644
--- a/abs/core-testing/pcre/PKGBUILD
+++ b/abs/core-testing/pcre/PKGBUILD
@@ -1,26 +1,24 @@
-# $Id: PKGBUILD 4449 2008-07-07 16:12:00Z eric $
+# $Id: PKGBUILD 11888 2008-09-06 03:23:26Z eric $
# Maintainer: Eric Belanger <eric@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net>
pkgname=pcre
-pkgver=7.7
-pkgrel=11
+pkgver=7.8
+pkgrel=1
pkgdesc="A library that implements Perl 5-style regular expressions"
arch=('i686' 'x86_64')
url="http://pcre.sourceforge.net"
-license=('custom')
+license=('BSD')
groups=('base')
depends=('gcc-libs')
options=('!libtool' '!makeflags')
-source=(ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${pkgname}-${pkgver}.tar.bz2 \
- libpcre-7.7-buffer-overflow.patch)
-md5sums=('4b2e9cde1f7227448dddba59843efa0b' 'ea2204b6a0cbc83b3ca925ace06459a1')
-sha1sums=('f1f54d3e13e6cb427de962e62eaaee32c74cba38' '5a69fb97f1fa547f9012082221a6b98d77b65277')
+source=(ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('141132d6af14dccc7b08fa797e4fd441')
+sha1sums=('552909f9d18e1954eec639f926957a4cb2de1ec3')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
[ "${CARCH}" = "x86_64" ] && export CFLAGS="${CFLAGS} -fPIC"
- patch -p1 < ../libpcre-7.7-buffer-overflow.patch || return 1
./configure --prefix=/usr --enable-utf8 --enable-unicode-properties || return 1
make || return 1
make DESTDIR=${pkgdir} install || return 1
@@ -28,5 +26,5 @@ build() {
mkdir -p ${pkgdir}/lib
mv ${pkgdir}/usr/lib/libpcre.so.* ${pkgdir}/lib/ || return 1
ln -sf ../../lib/libpcre.so.0 ${pkgdir}/usr/lib/libpcre.so || return 1
- install -D -m644 LICENCE ${pkgdir}/usr/share/licenses/${pkgname}/license.txt || return 1
+ install -D -m644 LICENCE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
}
diff --git a/abs/core-testing/php/PKGBUILD b/abs/core-testing/php/PKGBUILD
index 4b0a18b..5f34040 100644
--- a/abs/core-testing/php/PKGBUILD
+++ b/abs/core-testing/php/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=php
pkgver=5.2.6
-pkgrel=12
+pkgrel=13
_suhosinver=0.9.6.2
pkgdesc='A high-level scripting language'
arch=('i686' 'x86_64')
diff --git a/abs/core-testing/php/php.ini b/abs/core-testing/php/php.ini
index 50b0291..083baf4 100644
--- a/abs/core-testing/php/php.ini
+++ b/abs/core-testing/php/php.ini
@@ -127,7 +127,7 @@ zend.ze1_compatibility_mode = Off
; servers which are not under your control, because short tags may not
; be supported on the target server. For portable, redistributable code,
; be sure not to use short tags.
-short_open_tag = Off
+short_open_tag = On
; Allow ASP-style <% %> tags.
asp_tags = Off