summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-01 23:57:05 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-01 23:57:05 (GMT)
commit657aa7b8d352108a98719a22e6422b490e598d26 (patch)
treeb2259685fe6409f86d814a1703068ce0fcf0ace8 /abs/core-testing
parent3f300e50406f82e3fde4f48dd7c14fa79cbcd99a (diff)
parent61344e5f8def4236eadfb43c1efd30bc65c21394 (diff)
downloadlinhes_pkgbuild-657aa7b8d352108a98719a22e6422b490e598d26.zip
linhes_pkgbuild-657aa7b8d352108a98719a22e6422b490e598d26.tar.gz
linhes_pkgbuild-657aa7b8d352108a98719a22e6422b490e598d26.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing')
-rwxr-xr-xabs/core-testing/LinHES-config/install_functions.sh35
-rwxr-xr-xabs/core-testing/LinHES-config/mv_config.py2
-rw-r--r--abs/core-testing/dhcp/ChangeLog8
-rw-r--r--abs/core-testing/dhcp/PKGBUILD33
-rw-r--r--abs/core-testing/dhcp/dhcp-3.0.3-tr.c.patch10
-rw-r--r--abs/core-testing/dhcp/dhcp-4.1.0-missing-ipv6-not-fatal.patch50
-rw-r--r--abs/core-testing/dhcp/dhcp.conf.d6
-rwxr-xr-xabs/core-testing/dhcp/dhcpd3
-rw-r--r--abs/core-testing/dhcpcd/PKGBUILD61
-rw-r--r--abs/core-testing/local-website/PKGBUILD2
-rw-r--r--abs/core-testing/local-website/htdocs/index.html57
-rwxr-xr-xabs/core-testing/local-website/htdocs/mediaserv.php4
-rw-r--r--abs/core-testing/mythtv/stable/mythweb/PKGBUILD5
-rw-r--r--abs/core-testing/mythtv/stable/mythweb/transcoders.patch23
-rw-r--r--abs/core-testing/nvidia/PKGBUILD2
15 files changed, 214 insertions, 87 deletions
diff --git a/abs/core-testing/LinHES-config/install_functions.sh b/abs/core-testing/LinHES-config/install_functions.sh
index 29f57cc..0bc0591 100755
--- a/abs/core-testing/LinHES-config/install_functions.sh
+++ b/abs/core-testing/LinHES-config/install_functions.sh
@@ -200,6 +200,15 @@ function rest_of_network () {
else
printhl " DNS not found"
fi
+ echo $CMDLINE | grep -q chostname
+ if [ $? -eq 0 ]
+ then
+ TEMPVAR=${CMDLINE#*chostname=}
+ MYHOST=${TEMPVAR%% *}
+ update_db_settings HostMyhostname "$MYHOST"
+ else
+ printhl " hostname not found"
+ fi
}
function init_network {
@@ -259,6 +268,14 @@ function dev_up_check(){
}
function request_dhcp(){
+ echo $CMDLINE |grep -q cnetdev
+ if [ $? -eq 0 ]
+ then
+ TEMPVAR=${CMDLINE#*cnetdev=}
+ MYTHDEFAULT_NET=${TEMPVAR%% *}
+ else
+ MYTHDEFAULT_NET="eth0"
+ fi
for ndev in eth0 eth1 wlan0 wlan1 ath0
do
dev_up_check $ndev
@@ -266,22 +283,30 @@ function request_dhcp(){
if [ $status -eq 1 ]
then
#interface is down, lets see if dhcp responds
- dhcpcd -Td -t2 $ndev > /tmp/dhcpinfo.$ndev
- TEMPVAR=`grep IPADDR /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ dhcpcd -Td -t2 $ndev -h "" > /tmp/dhcpinfo.$ndev
+ #check for hostname here
+
+ TEMPVAR=`grep new_ip_address /tmp/dhcpinfo.$ndev |cut -d\= -f2`
if [ ! x$TEMPVAR = x ]
then
update_db_settings HostIP$ndev "$TEMPVAR"
- TEMPVAR=`grep NETMASK /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ TEMPVAR=`grep new_subnet_mask /tmp/dhcpinfo.$ndev |cut -d\= -f2`
nm=`/usr/bin/nmconv.py -obits $TEMPVAR`
TEMPVAR="/$nm $TEMPVAR"
update_db_settings HostNETMASK$ndev "$TEMPVAR"
- TEMPVAR=`grep GATEWAYS /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ TEMPVAR=`grep new_routers /tmp/dhcpinfo.$ndev |cut -d\= -f2`
update_db_settings HostGW$ndev "$TEMPVAR"
- TEMPVAR=`grep DNSSERVERS /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ TEMPVAR=`grep new_domain_name_servers /tmp/dhcpinfo.$ndev |cut -d\= -f2`
update_db_settings HostDNS$ndev "$TEMPVAR"
fi
fi
done
+ TEMPVAR=`grep new_host_name /tmp/dhcpinfo.$MYTHDEFAULT_NET |cut -d\= -f2`
+ if [ ! x$TEMPVAR = x ]
+ then
+ update_db_settings HostMyhostname "$TEMPVAR"
+ fi
+
}
function init_remote {
diff --git a/abs/core-testing/LinHES-config/mv_config.py b/abs/core-testing/LinHES-config/mv_config.py
index d5a247d..1ac4fea 100755
--- a/abs/core-testing/LinHES-config/mv_config.py
+++ b/abs/core-testing/LinHES-config/mv_config.py
@@ -10,7 +10,7 @@ NOOPDEBUG="FALSE"
BACKUPFILE="mythconverg.sql.gz"
BACKUPPATH="/myth/backup/"
TEMP_TEMPLATES="/tmp/templates"
-SMEDIA="/myth"
+SMEDIA="myth"
diff --git a/abs/core-testing/dhcp/ChangeLog b/abs/core-testing/dhcp/ChangeLog
new file mode 100644
index 0000000..7b9cb47
--- /dev/null
+++ b/abs/core-testing/dhcp/ChangeLog
@@ -0,0 +1,8 @@
+
+2009-07-19 K. Piche <kevin@archlinux.org>
+ * dhcp 4.1.0.p1-1
+ * Adopted RedHat patch to fix bug where dhcpd won't start if ipv6 module
+ is not loaded. Fixes FS#12792.
+ * Added /etc/conf.d/dhcp feature contributed by Fabiano Furtado Pessoa
+ Coelho <fusca14@gmail.com>
+
diff --git a/abs/core-testing/dhcp/PKGBUILD b/abs/core-testing/dhcp/PKGBUILD
index f426778..db15ac3 100644
--- a/abs/core-testing/dhcp/PKGBUILD
+++ b/abs/core-testing/dhcp/PKGBUILD
@@ -1,46 +1,39 @@
-# $Id: PKGBUILD 23123 2009-01-03 02:43:02Z kevin $
+# $Id: PKGBUILD 46754 2009-07-20 03:16:44Z kevin $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=dhcp
-pkgver=4.1.0
+# separate patch levels with a period to maintain proper versioning.
+pkgver=4.1.0.p1
+_pkgver=4.1.0p1
pkgrel=1
pkgdesc="A DHCP server, client, and relay agent"
arch=(i686 x86_64)
license=('custom:isc-dhcp')
-url="http://www.isc.org/sw/dhcp/"
+url="https://www.isc.org/software/dhcp"
depends=('openssl>=0.9.8a')
-backup=('etc/dhcpd.conf' 'etc/dhclient.conf')
+backup=('etc/dhcpd.conf' 'etc/conf.d/dhcp')
install=dhcp.install
-source=(http://ftp.isc.org/isc/dhcp/dhcp-${pkgver}.tar.gz dhcp-3.0.3-tr.c.patch
-dhcpd)
-md5sums=('1fffed2e8c3d67b111316d6a9b33db7a' '39866416303b674df08b66b2d094e523'
- '025b8fe98b6c0814428b671b1819a810')
+source=(http://ftp.isc.org/isc/${pkgname}/${pkgname}-${_pkgver}.tar.gz
+dhcpd dhcp.conf.d dhcp-4.1.0-missing-ipv6-not-fatal.patch)
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -p1 -i ../dhcp-3.0.3-tr.c.patch || return 1
+ cd ${srcdir}/${pkgname}-${_pkgver}
# Define _GNU_SOURCE to fix IPV6.
sed '/^CFLAGS="$CFLAGS/ s/INGS"/INGS -D_GNU_SOURCE"/' -i configure
+ # Make not having ipv6 non-fatal.
+ patch -Np1 -i ${srcdir}/dhcp-4.1.0-missing-ipv6-not-fatal.patch
./configure --prefix=/usr --sysconfdir=/etc \
--with-srv-lease-file=/var/state/dhcp/dhcpd.leases \
--with-srv6-lease-file=/var/state/dhcp/dhcpd6.leases
make || return 1
make DESTDIR=${pkgdir} install
- #install -D -m644 server/dhcpd.conf ${pkgdir}/etc/dhcpd.conf
- #install -D -m644 client/dhclient.conf ${pkgdir}/etc/dhclient.conf
install -D -m755 ${srcdir}/dhcpd ${pkgdir}/etc/rc.d/dhcpd
+ install -D -m644 ${srcdir}/dhcp.conf.d ${pkgdir}/etc/conf.d/${pkgname}
mkdir -p ${pkgdir}/var/state/dhcp
- #touch ${pkgdir}/var/state/dhcp/dhcpd.leases
- #chmod -R 644 ${pkgdir}/usr/share/man/*
- #chmod 755 ${pkgdir}/usr/share/man/man{1,3,5,8}
- #sed -i 's|etc/dhclient-script|sbin/dhclient-script|g' \
- #${pkgdir}/etc/dhclient.conf
- #rm -f ${pkgdir}/var/state/dhcp/dhcpd.leases
- #rm -f ${pkgdir}/sbin/{dhclient,dhclient-script}
rm -f ${pkgdir}/etc/dhclient.conf
rm -f ${pkgdir}/usr/sbin/dhclient
rm -f ${pkgdir}/usr/share/man/man{5,8}/dhclient*
# install licenses
- install -m644 -D ${srcdir}/${pkgname}-${pkgver}/LICENSE \
+ install -m644 -D ${srcdir}/${pkgname}-${_pkgver}/LICENSE \
${pkgdir}/usr/share/licenses/dhcp/LICENSE
}
diff --git a/abs/core-testing/dhcp/dhcp-3.0.3-tr.c.patch b/abs/core-testing/dhcp/dhcp-3.0.3-tr.c.patch
deleted file mode 100644
index e262c5e..0000000
--- a/abs/core-testing/dhcp/dhcp-3.0.3-tr.c.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- work.linux-2.2/common/tr.c 2005/08/14 11:34:24 1.1
-+++ work.linux-2.2/common/tr.c 2005/08/14 11:35:16
-@@ -40,6 +40,7 @@ static char copyright[] =
- #include "includes/netinet/if_ether.h"
- #include "netinet/if_tr.h"
- #include <sys/time.h>
-+#include <linux/types.h>
-
- /*
- * token ring device handling subroutines. These are required as token-ring
diff --git a/abs/core-testing/dhcp/dhcp-4.1.0-missing-ipv6-not-fatal.patch b/abs/core-testing/dhcp/dhcp-4.1.0-missing-ipv6-not-fatal.patch
new file mode 100644
index 0000000..ebf3865
--- /dev/null
+++ b/abs/core-testing/dhcp/dhcp-4.1.0-missing-ipv6-not-fatal.patch
@@ -0,0 +1,50 @@
+diff -Naur dhcp-4.1.0a2/common/discover.c dhcp-4.1.0a2-mcn/common/discover.c
+--- dhcp-4.1.0a2/common/discover.c 2008-08-29 18:48:57.000000000 +0100
++++ dhcp-4.1.0a2-mcn/common/discover.c 2008-10-02 13:02:06.000000000 +0100
+@@ -443,15 +443,17 @@
+ }
+
+ #ifdef DHCPv6
+- ifaces->fp6 = fopen("/proc/net/if_inet6", "r");
+- if (ifaces->fp6 == NULL) {
+- log_error("Error opening '/proc/net/if_inet6' to "
+- "list IPv6 interfaces; %m");
+- close(ifaces->sock);
+- ifaces->sock = -1;
+- fclose(ifaces->fp);
+- ifaces->fp = NULL;
+- return 0;
++ if (local_family == AF_INET6) {
++ ifaces->fp6 = fopen("/proc/net/if_inet6", "r");
++ if (ifaces->fp6 == NULL) {
++ log_error("Error opening '/proc/net/if_inet6' to "
++ "list IPv6 interfaces; %m");
++ close(ifaces->sock);
++ ifaces->sock = -1;
++ fclose(ifaces->fp);
++ ifaces->fp = NULL;
++ return 0;
++ }
+ }
+ #endif
+
+@@ -720,7 +722,8 @@
+ }
+ #ifdef DHCPv6
+ if (!(*err)) {
+- return next_iface6(info, err, ifaces);
++ if (local_family == AF_INET6)
++ return next_iface6(info, err, ifaces);
+ }
+ #endif
+ return 0;
+@@ -736,7 +739,8 @@
+ close(ifaces->sock);
+ ifaces->sock = -1;
+ #ifdef DHCPv6
+- fclose(ifaces->fp6);
++ if (local_family == AF_INET6)
++ fclose(ifaces->fp6);
+ ifaces->fp6 = NULL;
+ #endif
+ }
diff --git a/abs/core-testing/dhcp/dhcp.conf.d b/abs/core-testing/dhcp/dhcp.conf.d
new file mode 100644
index 0000000..99ba6d1
--- /dev/null
+++ b/abs/core-testing/dhcp/dhcp.conf.d
@@ -0,0 +1,6 @@
+#
+# Arguments to be passed to the DHCP server daemon
+#
+
+DHCP_ARGS="-q"
+
diff --git a/abs/core-testing/dhcp/dhcpd b/abs/core-testing/dhcp/dhcpd
index 0aebcc8..1fbb31e 100755
--- a/abs/core-testing/dhcp/dhcpd
+++ b/abs/core-testing/dhcp/dhcpd
@@ -2,6 +2,7 @@
. /etc/rc.conf
. /etc/rc.d/functions
+. /etc/conf.d/dhcp
PIDFILE="/var/run/dhcpd.pid"
PID=`cat $PIDFILE 2>/dev/null`
@@ -9,7 +10,7 @@ case "$1" in
start)
stat_busy "Starting DHCP Server"
if [ "$PID" = "" ]; then
- /usr/sbin/dhcpd -q
+ /usr/sbin/dhcpd $DHCP_ARGS
fi
if [ "$PID" != "" -o $? -gt 0 ]; then
stat_fail
diff --git a/abs/core-testing/dhcpcd/PKGBUILD b/abs/core-testing/dhcpcd/PKGBUILD
index dfc1914..1cfb7f9 100644
--- a/abs/core-testing/dhcpcd/PKGBUILD
+++ b/abs/core-testing/dhcpcd/PKGBUILD
@@ -1,27 +1,48 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: judd <jvinet@zeroflux.org>
+
pkgname=dhcpcd
-pkgver=3.2.1
-pkgrel=10
-pkgdesc="A DHCP client daemon"
-arch=(i686 x86_64)
+pkgver=5.0.7
+pkgrel=1
+pkgdesc="RFC2131 compliant DHCP client daemon"
+url="http://roy.marples.name/dhcpcd/"
+arch=('i686' 'x86_64')
license=('BSD')
-url="http://roy.marples.name/dhcpcd"
groups=('base')
-depends=('glibc')
-backup=('etc/conf.d/dhcpcd')
-source=(http://roy.marples.name/dhcpcd/$pkgname-$pkgver.tar.bz2
- dhcpcd.conf.d)
-md5sums=('5a437882b6b9eb29bde323dc411be4a4'
- '12d866a78d9f5fa5f31ca18b3940d847')
+depends=('glibc' 'bash')
+backup=('etc/conf.d/dhcpcd' 'etc/dhcpcd.conf')
+options=('emptydirs') # We Need the Empty /var/lib/dhcpcd Directory
+source=("http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2" \
+ 'dhcpcd.conf.d')
build() {
- cd $startdir/src/$pkgname-$pkgver
- #disable DUID usage
- echo "#undef ENABLE_DUID" >> config.h
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # Fix Installation Locations
+ export PREFIX=/usr
+ sed -i 's/${PREFIX}\/etc/\/etc/' Makefile || return 1
+ sed -i 's/\/db/\/lib\/dhcpcd/' Makefile || return 1
+ sed -i 's/\/libexec/\/lib\/dhcpcd/' Makefile || return 1
+ sed -i 's/\/libexec/\/lib\/dhcpcd/' dhcpcd-hooks/Makefile || return 1
+ sed -i 's/${PREFIX}\/sbin/\/sbin/' Makefile || return 1
+
+ # Build
make || return 1
- make DESTDIR=$startdir/pkg install
- mkdir -p $startdir/pkg/usr/sbin
- ln -sf /sbin/dhcpcd $startdir/pkg/usr/sbin/dhcpcd
- install -D -m644 ../dhcpcd.conf.d $startdir/pkg/etc/conf.d/dhcpcd
+ make DESTDIR=${pkgdir} install || return 1
+
+ # Create Binary Symlink
+ install -d ${pkgdir}/usr/sbin || return 1
+ ln -sf /sbin/dhcpcd ${pkgdir}/usr/sbin/dhcpcd || return 1
+
+ # Install Configuration File used in /etc/rc.d/network
+ install -D -m644 ../dhcpcd.conf.d $pkgdir/etc/conf.d/$pkgname || return 1
+
+ # Install License
+ install -d $pkgdir/usr/share/licenses/$pkgname || return 1
+ awk '{if(FNR<27)print $0}' ${srcdir}/${pkgname}-${pkgver}/config.h \
+ >> ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+
+ # Make Man Pages FHS Compliant
+ mv -f ${pkgdir}/usr/man ${pkgdir}/usr/share/man || return 1
+
+ # Set Options in /etc/dhcpcd.conf
+ echo noipv4ll >> ${pkgdir}/etc/dhcpcd.conf || return 1 # Disable ip4vall
}
diff --git a/abs/core-testing/local-website/PKGBUILD b/abs/core-testing/local-website/PKGBUILD
index a47c062..c596881 100644
--- a/abs/core-testing/local-website/PKGBUILD
+++ b/abs/core-testing/local-website/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=local-website
pkgver=2
-pkgrel=8
+pkgrel=9
pkgdesc="Contents of http://localhost"
arch=(i686 x86_64)
license=('GPL')
diff --git a/abs/core-testing/local-website/htdocs/index.html b/abs/core-testing/local-website/htdocs/index.html
index 14d5c22..4cd5736 100644
--- a/abs/core-testing/local-website/htdocs/index.html
+++ b/abs/core-testing/local-website/htdocs/index.html
@@ -1,6 +1,7 @@
-<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
-<html>
-<head>
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
+<html><head>
+
+
<meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
@@ -11,13 +12,10 @@
- <title>LinHES R6</title>
- <link href="KnoppMyth.css" rel="stylesheet" type="text/css">
-</head>
-
-
+
+ <title>LinHES R6</title><link href="KnoppMyth.css" rel="stylesheet" type="text/css"></head>
<body>
-<p align="center"><a href="http://www.mysettopbox.tv">
+<p align="center"><a href="http://www.mysettopbox.tv/">
<img src="header.png" alt="Tux with a Remote" align="middle" border="0"></a>
</p>
@@ -34,7 +32,7 @@
<p class="headerimage" align="center"><b>The Linux Home Entertainment System Release 6</b></p>
- <p><a href="mythweb/mythweb.php"><b>MythWeb</b></a>: <br>
+ <p><a href="http://192.168.1.253/mythweb/mythweb.php"><b>MythWeb</b></a>: <br>
&nbsp; &nbsp; The MythWeb allows you to use a web page to control
aspects of your MythTV system. MythWeb is a separate application,
@@ -42,7 +40,7 @@
</p>
- <p><a href="remote/index.html"><b>MythTV Web Virtual Remote</b></a>: <br>
+ <p><a href="http://192.168.1.253/remote/index.html"><b>MythTV Web Virtual Remote</b></a>: <br>
&nbsp; &nbsp; A web based virtual remote control for MythTV.
&nbsp;In order for this to work, you must enable
@@ -51,26 +49,26 @@
</p>
- <p><a href="mythtv-doc/mythtv-HOWTO.html"><b>MythTV Documentation</b></a>: <br>
+ <p><a href="http://192.168.1.253/mythtv-doc/mythtv-HOWTO.html"><b>MythTV Documentation</b></a>: <br>
&nbsp; &nbsp; The MythTV Installation / User's Guide.
</p>
- <p><a href="mythtv-doc/keys.txt"><b>MythTV Keybindings</b></a>: <br>
+ <p><a href="http://192.168.1.253/mythtv-doc/keys.txt"><b>MythTV Keybindings</b></a>: <br>
&nbsp; &nbsp; The keybindings for the normal MythTV interface.
</p>
- <p><a href="linhes.html"><b>LinHES</b></a>: <br>
+ <p><a href="http://192.168.1.253/linhes.html"><b>LinHES</b></a>: <br>
&nbsp; &nbsp; Describes how "The Project Leader" setup multiple systems
to form a <b>Lin</b>ux <b>H</b>ome <b>E</b>ntertainment <b>S</b>ystem.
</p>
- <p><a href="folding@home/"><b>My Folding Status</b></a>: <br>
+ <p><a href="http://192.168.1.253/folding@home/"><b>My Folding Status</b></a>: <br>
&nbsp; &nbsp; Status of the folding@home work for the local user.
</p>
@@ -82,24 +80,32 @@
</p>
- <p><a href="ipodfeed/"><b>iPod Feeds</b></a> <br>
+ <p><a href="http://192.168.1.253/ipodfeed/"><b>iPod Feeds</b></a> <br>
- &nbsp; &nbsp; Transcodes ready for the ipod (if any).</p>
-<a href="archive"><b>XviD Feed dir</b></a> <br>
- &nbsp; &nbsp; Any programs you transcodes to XviD.</p>
- <p><a style="font-weight: bold;" href="fuppes.php"><span style="text-decoration: underline;">FUPPES</span></a><br>
+ &nbsp; &nbsp; Transcodes ready for the ipod (if any). &nbsp;Additionally, you can delete unwanted files using this <a href="/ipodfeed/m2iweb.php">link</a>. &nbsp;Note: &nbsp;If you have no recordings, you will see a warning issued from PHP.</p>
+<a href="http://192.168.1.253/archive"><b>XviD Feed dir</b></a> <br>
+&nbsp; &nbsp; Any programs you have transcoded to XviD.
+&nbsp;Additionally, you can delete unwanted files using this <a href="/archive/archive.php">link</a>. &nbsp;Note: &nbsp;If you have no recordings, you will see a warning issued from PHP.
+ <p><a style="font-weight: bold;" href="http://192.168.1.253/fuppes.php"><span style="text-decoration: underline;">FUPPES</span></a><br>
&nbsp;&nbsp;&nbsp; FUPPES - Free UPnP Entertainment Service. &nbsp;A
UPnP to be used inplace of the UPnP server that comes with MythTV.
&nbsp;If the UPnP that comes with MythTV doesn't work for you, you can
-try FUPPES.
-
- <p><a href="rrd/index.html"><b>RRDTool</b></a>: <br>
+try FUPPES.</p><p><a style="font-weight: bold;" href="http://192.168.1.253/mediaserv.php"><span style="text-decoration: underline;">Mediaserv</span></a><br>
+&nbsp;&nbsp;&nbsp; Mediaserv - A on-demand transcoding server for
+videos. &nbsp;Mediaserv is designed to transcode video in a format
+playable on the Nokia Internet Tablets. &nbsp;However it works well at
+transcoding and streaming&nbsp;to any device. &nbsp;As longs as the
+device will playback AVIs (think streaming to any browser!). &nbsp;By
+default, we have it set to link to
+TV recordings (pretty) and your video directory. &nbsp;Additionally if
+you want it to stream contents from a network share, it will! &nbsp;ln
+-s /path/to/share /myth/mediaserv/media/ </p><p><a href="http://192.168.1.253/rrd/index.html"><b>RRDTool</b></a>: <br>
&nbsp; &nbsp; Hardware status graphs.
</p>
- <p><a href="javascript:void(0)"onclick="window.open('mythweb/data/mp3player.html','linkname','height=100, width=260,scrollbars=no')"><b>KnoppMyth Radio</b></a>: <br>
+ <p><a href="javascript:void(0)" onclick="window.open('mythweb/data/mp3player.html','linkname','height=100, width=260,scrollbars=no')"><b>KnoppMyth Radio</b></a>: <br>
&nbsp; &nbsp; Your music must be encoded as MP3 in MythMusic for this to work.</p>
@@ -114,5 +120,4 @@ try FUPPES.
</table>
-</body>
-</html>
+</body></html>
diff --git a/abs/core-testing/local-website/htdocs/mediaserv.php b/abs/core-testing/local-website/htdocs/mediaserv.php
new file mode 100755
index 0000000..832dec5
--- /dev/null
+++ b/abs/core-testing/local-website/htdocs/mediaserv.php
@@ -0,0 +1,4 @@
+<?php
+$HTTP_HOST = getenv('HTTP_HOST');
+header("Location: http://$HTTP_HOST:8090/");
+?>
diff --git a/abs/core-testing/mythtv/stable/mythweb/PKGBUILD b/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
index 3e3d172..20e9e3d 100644
--- a/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=mythweb
pkgver=0.21
-pkgrel=19
+pkgrel=20
pkgdesc="Web interface for MythTV's backend"
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
license=('GPL')
depends=("mythtv>=${pkgver}" 'lighttpd' 'php' 'local-website')
install=mythweb.install
-source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2" wiiweb.tar.bz2)
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2" wiiweb.tar.bz2 transcoders.patch)
md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe')
groups=('mythtv-extras')
DOCROOT=/data/srv/httpd/htdocs/mythweb
@@ -26,6 +26,7 @@ build() {
# Workaround for LIGHTTPD bug in mythweb.pl (affects DB queries)
cd $startdir/src/mythplugins/$pkgname/
patch -p0 < $startdir/patch/mythweb.pl.diff
+ patch -p1 < $startdir/transcoders.patch
cp -r $startdir/src/mythplugins/$pkgname/* $startdir/pkg/$DOCROOT
# cp $startdir/src/mythplugins-$pkgver/$pkgname/data/.htaccess $startdir/pkg/$DOCROOT
diff --git a/abs/core-testing/mythtv/stable/mythweb/transcoders.patch b/abs/core-testing/mythtv/stable/mythweb/transcoders.patch
new file mode 100644
index 0000000..c1aeb6c
--- /dev/null
+++ b/abs/core-testing/mythtv/stable/mythweb/transcoders.patch
@@ -0,0 +1,23 @@
+diff -ruaN mythweb.orig/modules/_shared/lang/English.lang mythweb/modules/_shared/lang/English.lang
+--- mythweb.orig/modules/_shared/lang/English.lang 2009-01-09 02:44:23.000000000 +0000
++++ mythweb/modules/_shared/lang/English.lang 2009-07-31 06:29:11.000000000 +0000
+@@ -816,3 +816,5 @@
+ "Year"
+ "Yes"
+ "Yesterday"
++"Myth2iPod"
++"Myt2XviD3"
+diff -ruaN mythweb.orig/modules/_shared/tmpl/default/header.php mythweb/modules/_shared/tmpl/default/header.php
+--- mythweb.orig/modules/_shared/tmpl/default/header.php 2009-01-09 02:44:23.000000000 +0000
++++ mythweb/modules/_shared/tmpl/default/header.php 2009-07-31 06:28:54.000000000 +0000
+@@ -171,6 +171,10 @@
+ <a href="<?php echo root ?>tv/recorded"><?php echo t('Recorded Programs') ?></a>
+ &nbsp; | &nbsp;
+ <a href="<?php echo root ?>status"><?php echo t('Backend Status') ?></a>
++ &nbsp; | &nbsp;
++ <a href="/ipodfeed/m2iweb.php"><?php echo t('Myth2iPod') ?></a>
++ &nbsp; | &nbsp;
++ <a href="/archive/archive.php"><?php echo t('Myt2XviD3') ?></a>
+ <?php if ($Modules['backend_log']) { ?>
+ &nbsp; | &nbsp;
+ <a href="<?php echo root ?>backend_log"><?php echo t('Backend Logs') ?></a>
diff --git a/abs/core-testing/nvidia/PKGBUILD b/abs/core-testing/nvidia/PKGBUILD
index e8469c8..252a746 100644
--- a/abs/core-testing/nvidia/PKGBUILD
+++ b/abs/core-testing/nvidia/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=nvidia
pkgver=185.18.14
_kernver='2.6.28-LinHES'
-pkgrel=3
+pkgrel=4
pkgdesc="NVIDIA drivers for kernel26."
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && ARCH=x86