summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-05-20 02:51:25 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-05-20 02:51:25 (GMT)
commitab2f6a2a66c7e2b47d03da81e72109aa96fd9c2c (patch)
tree7b5db6af9db2113343a65fbac37e4821d939ba3c /abs/core-testing
parentc1fb5b95e554560a87424a6f3334abf049f999b8 (diff)
parente7cd231a27e5f65ed92b56c85e0e05aeb3645132 (diff)
downloadlinhes_pkgbuild-ab2f6a2a66c7e2b47d03da81e72109aa96fd9c2c.zip
linhes_pkgbuild-ab2f6a2a66c7e2b47d03da81e72109aa96fd9c2c.tar.gz
linhes_pkgbuild-ab2f6a2a66c7e2b47d03da81e72109aa96fd9c2c.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/libjpeg/PKGBUILD23
-rw-r--r--abs/core-testing/mythtv/trunk/morethemes/PKGBUILD2
-rwxr-xr-xabs/core-testing/mythtv/trunk/mp_all.sh2
-rw-r--r--abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythflix/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythgame/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythnews/PKGBUILD2
-rwxr-xr-xabs/core-testing/mythtv/trunk/myththemes/PKGBUILD2
-rwxr-xr-xabs/core-testing/mythtv/trunk/mythtv/PKGBUILD4
-rw-r--r--abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythweather/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythweb/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD2
-rw-r--r--abs/core-testing/qt/PKGBUILD88
-rw-r--r--abs/core-testing/qt/assistant.desktop (renamed from abs/core-testing/qt/qt4-assistant.desktop)6
-rw-r--r--abs/core-testing/qt/designer.desktop (renamed from abs/core-testing/qt/qt4-designer.desktop)4
-rw-r--r--abs/core-testing/qt/linguist.desktop (renamed from abs/core-testing/qt/qt4-linguist.desktop)4
-rw-r--r--abs/core-testing/qt/qdoc3.patch22
-rw-r--r--abs/core-testing/qt/qtconfig.desktop8
23 files changed, 103 insertions, 86 deletions
diff --git a/abs/core-testing/libjpeg/PKGBUILD b/abs/core-testing/libjpeg/PKGBUILD
index 807f7f5..baedcd4 100644
--- a/abs/core-testing/libjpeg/PKGBUILD
+++ b/abs/core-testing/libjpeg/PKGBUILD
@@ -1,21 +1,28 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: dorphell <dorphell@archlinux.org>
+# $Id$
+# Maintainer: Allan McRae <allan@archlinux.org>
# Committer: Judd Vinet <jvinet@zeroflux.org>
+
pkgname=libjpeg
pkgver=6b
-pkgrel=4
+pkgrel=6
pkgdesc="Library of JPEG support functions"
arch=('i686' 'x86_64')
+url="http://www.ijg.org/"
+license=('custom')
depends=('glibc')
+makedepends=('libtool')
+options=(!libtool)
source=(ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v$pkgver.tar.gz)
md5sums=('dbd5f3b47ed13132f04c685d608a7547')
build() {
- cd $startdir/src/jpeg-$pkgver
+ cd $srcdir/jpeg-$pkgver
+ cp /usr/share/libtool/config/config.{guess,sub} .
+ sed -i "s#./libtool#libtool#" configure
./configure --prefix=/usr --enable-shared --enable-static
make || return 1
- mkdir -p $startdir/pkg/usr/{bin,lib,include,man/man1}
- make prefix=$startdir/pkg/usr install
-
- find $startdir/pkg -name '*.la' -exec rm {} \;
+ mkdir -p $pkgdir/usr/{bin,lib,include,share/man/man1}
+ make prefix=$pkgdir/usr mandir=$pkgdir/usr/share/man/man1 install
+ install -m644 jpegint.h $pkgdir/usr/include
+ install -Dm644 README $pkgdir/usr/share/licenses/libjpeg/README
}
diff --git a/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD b/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD
index 1117ef7..4e920a7 100644
--- a/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=morethemes-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Additional themes for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mp_all.sh b/abs/core-testing/mythtv/trunk/mp_all.sh
index 6562fc8..aa95719 100755
--- a/abs/core-testing/mythtv/trunk/mp_all.sh
+++ b/abs/core-testing/mythtv/trunk/mp_all.sh
@@ -1,5 +1,5 @@
#!/bin/sh
-_svnver=20414
+_svnver=20586
# NOTE: Make sure to build and install mythtv first BEFORE building anything else
buildlist=('mythtv' 'mytharchive' 'mythbrowser' 'mythflix' 'mythgallery' 'mythgame' 'mythmovies' 'mythmusic' 'mythnews' 'mythvideo' 'mythweather' 'mythzoneminder' 'mythweb' 'myththemes' 'morethemes')
diff --git a/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD b/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
index 107e551..d4967a7 100644
--- a/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mytharchive-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="MythTV plugin that lets you create DVDs from or archive your recorded shows."
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD b/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
index c00c9a2..8152586 100644
--- a/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythbrowser-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Mini web browser for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythflix/PKGBUILD b/abs/core-testing/mythtv/trunk/mythflix/PKGBUILD
index 20a7831..d5ed49f 100644
--- a/abs/core-testing/mythtv/trunk/mythflix/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythflix/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythflix-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Netflix access plugin for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD b/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
index 8af88f9..d849c09 100644
--- a/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythgallery-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Image gallery plugin for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD b/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD
index 4cb12ed..e2431b8 100644
--- a/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythgame-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Emulation plugin for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD b/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
index 75d2b7f..846dc17 100644
--- a/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythmovies-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Displays information about movies playing in the area."
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD b/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD
index b00c40b..9af2e84 100644
--- a/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythmusic-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Music playing plugin for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD b/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD
index 99200d0..33c7b02 100644
--- a/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythnews-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="News checking plugin for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD b/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD
index 16b09bb..f20a50e 100755
--- a/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=myththemes-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Themes for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index 3fb2082..b2b943e 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythtv-svn
-pkgver=20414
-pkgrel=3
+pkgver=20586
+pkgrel=1
pkgdesc="A personal video recorder for Linux"
url="http://www.mythtv.org"
license="GPL"
diff --git a/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD b/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD
index 9b1e6e8..a8598c1 100644
--- a/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythvideo-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Video playback and browsing plugin for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD b/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
index 95e42ae..c4beb8c 100644
--- a/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythweather-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Weather checking plugin for MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD b/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
index 4f7f3ab..533e4f4 100644
--- a/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythweb-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Web interface for MythTV's backend"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD b/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD
index bdd4c3f..398253e 100644
--- a/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythzoneminder-svn
-pkgver=20414
+pkgver=20586
pkgrel=1
pkgdesc="Integrates ZoneMinder into MythTV"
url="http://www.mythtv.org"
diff --git a/abs/core-testing/qt/PKGBUILD b/abs/core-testing/qt/PKGBUILD
index a06b7e0..b581564 100644
--- a/abs/core-testing/qt/PKGBUILD
+++ b/abs/core-testing/qt/PKGBUILD
@@ -1,31 +1,34 @@
-# $Id: PKGBUILD 18501 2008-11-06 12:11:46Z pierre $
+# $Id$
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=qt
-pkgver=4.4.3
+pkgver=4.5.1
pkgrel=2
-_qtcopyver=880178
-pkgdesc="The QT gui toolkit."
+_qtcopyver=958581
+pkgdesc='A cross-platform application and UI framework'
arch=('i686' 'x86_64')
-url="http://www.trolltech.com/products/qt"
-license=('GPL3')
-options=('!libtool' '!docs')
-depends=('libpng' 'libxi' 'mesa' 'fontconfig' 'libxrandr' 'glib2' 'libtiff' 'libmng' 'sqlite3' 'dbus' 'libxcursor' 'libxinerama')
+url='http://www.qtsoftware.com/'
+license=('GPL3' 'LGPL')
+depends=('libpng' 'mesa' 'fontconfig' 'libtiff' 'libmng' 'sqlite3' 'libxrandr' 'glib2' 'libxi' 'dbus' 'libxcursor' 'libxinerama' 'libxrender')
optdepends=('postgresql-libs' 'libmysqlclient' 'unixodbc')
makedepends=('inputproto' 'postgresql-libs' 'mysql' 'unixodbc' 'libxfixes')
provides=("qt4=${pkgver}")
replaces=('qt4')
conflicts=('qt4')
-_pkgfqn=qt-x11-opensource-src-$pkgver
-# svn export -r -${_qtcopyver} svn://anonsvn.kde.org/home/kde/trunk/qt-copy/patches/ qt-copy-patches-${_qtcopyver}
-source=("ftp://ftp.trolltech.com/qt/source/${_pkgfqn}.tar.bz2"
+options=('!libtool')
+_pkgfqn="qt-x11-opensource-src-${pkgver}"
+# svn export -r${_qtcopyver} svn://anonsvn.kde.org/home/kde/trunk/qt-copy/patches/ qt-copy-patches-${_qtcopyver}
+source=("ftp://ftp.qtsoftware.com/qt/source/${_pkgfqn}.tar.bz2"
"ftp://ftp.archlinux.org/other/qt/qt-copy-patches-${_qtcopyver}.tar.bz2"
- 'qt4-assistant.desktop' 'qt4-designer.desktop' 'qt4-linguist.desktop')
-md5sums=('00e00c6324d342a7b0d8653112b4f08c'
- 'd3a40d783528a86174b62ecfc136b031'
- 'c95e1697bf2b923199c3b8cd7d485a17'
- '00333dca87e24767383217ba378b5980'
- '71f7ac8206c19da7ecf71cdb391f0452')
+ 'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qtconfig.desktop'
+ 'qdoc3.patch')
+md5sums=('afc43e566341cf3e5ed0bcb974f0c3b2'
+ 'b57b08ac7f990f91b85a7b1b1106e36b'
+ 'b352b4b70faba2571af3fce5d119580a'
+ '491a96682faa03407f768a53cca71db5'
+ 'cda7ed7e132689991dc2968a0043b4b0'
+ '717669b728a0a795217d2f52969e454c'
+ '868056a3edab09fbac0f82ec8b4a4be3')
build() {
unset QMAKESPEC
@@ -39,58 +42,41 @@ build() {
patch -p0 -i $i || return 1
done
- # remove unwanted mkspecs
- cd mkspecs/
- find . -maxdepth 1 -regextype posix-egrep -type d ! -regex "./linux.*|./common|./features|./qws" -exec rm -rf "{}" \;
- cd qws
- find . -maxdepth 1 -regextype posix-egrep -type d ! -regex "./linux.*" -exec rm -rf "{}" \;
- cd ../../
+ patch -p1 -i $srcdir/qdoc3.patch
- sed -i 's|-cp -P -f|-cp -L -f|' qmake/Makefile.unix
sed -i "s|-O2|$CXXFLAGS|" mkspecs/common/g++.conf
- # fix postgres build
- sed -e '/pg_config --libs/d' -i configure
- # do not compile demos, examples and docs
- sed -i 's|CFG_NOBUILD_PARTS=""|CFG_NOBUILD_PARTS="demos examples docs"|' configure
- ./configure -confirm-license \
+ ./configure -confirm-license -opensource \
+ -silent \
-prefix /usr \
- -docdir /usr/share/doc/qt \
+ -sysconfdir /etc \
-plugindir /usr/lib/qt/plugins \
- -datadir /usr/share/qt \
-translationdir /usr/share/qt/translations \
- -sysconfdir /etc \
+ -datadir /usr/share/qt \
+ -docdir /usr/share/doc/qt \
-examplesdir /usr/share/doc/qt/examples \
-demosdir /usr/share/doc/qt/demos \
- -no-exceptions \
+ -no-separate-debug-info \
-plugin-sql-{psql,mysql,sqlite,odbc} \
-system-sqlite \
- -no-phonon \
- -dbus-linked \
- -webkit \
- -no-separate-debug-info \
+ -openssl-linked \
+ -nomake demos \
-nomake examples \
-nomake docs \
- -nomake demos \
- -assistant-webkit \
- -system-libpng \
- -system-libjpeg \
- -system-zlib \
- -openssl-linked \
- -reduce-relocations \
- -xinerama \
- -xcursor \
- -xfixes \
- -optimized-qmake || return 1
+ -no-phonon \
+ -optimized-qmake \
+ -reduce-relocations
- make || return 1
- make INSTALL_ROOT=$pkgdir install || return 1
+ make
+ make INSTALL_ROOT=$pkgdir install
install -D -m644 tools/assistant/tools/assistant/images/assistant.png ${pkgdir}/usr/share/pixmaps/assistant.png
install -D -m644 tools/linguist/linguist/images/appicon.png ${pkgdir}/usr/share/pixmaps/linguist.png
install -D -m644 tools/designer/src/designer/images/designer.png ${pkgdir}/usr/share/pixmaps/designer.png
+ install -D -m644 src/gui/dialogs/images/qtlogo-64.png ${pkgdir}/usr/share/pixmaps/qtlogo.png
install -d ${pkgdir}/usr/share/applications
- install -m644 ${srcdir}/qt4-{linguist,designer,assistant}.desktop ${pkgdir}/usr/share/applications/
+ install -m644 ${srcdir}/{linguist,designer,assistant,qtconfig}.desktop ${pkgdir}/usr/share/applications/
+ install -D -m644 LGPL_EXCEPTION.txt ${pkgdir}/usr/share/licenses/qt/LGPL_EXCEPTION.txt
# cleanup and path fixes
find $pkgdir/usr/lib -type f -name '*prl' -print -exec sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" {} \;
diff --git a/abs/core-testing/qt/qt4-assistant.desktop b/abs/core-testing/qt/assistant.desktop
index 5d64aba..48105b9 100644
--- a/abs/core-testing/qt/qt4-assistant.desktop
+++ b/abs/core-testing/qt/assistant.desktop
@@ -1,9 +1,7 @@
[Desktop Entry]
-Encoding=UTF-8
Exec=/usr/bin/assistant
-Name=Qt 4 Assistant
-GenericName=Qt4 Document Browser
-X-KDE-StartupNotify=true
+Name=Qt Assistant
+GenericName=Qt Document Browser
Icon=/usr/share/pixmaps/assistant.png
Terminal=false
Type=Application
diff --git a/abs/core-testing/qt/qt4-designer.desktop b/abs/core-testing/qt/designer.desktop
index f4f91e8..fefe095 100644
--- a/abs/core-testing/qt/qt4-designer.desktop
+++ b/abs/core-testing/qt/designer.desktop
@@ -1,9 +1,7 @@
[Desktop Entry]
-Encoding=UTF-8
Exec=/usr/bin/designer
-Name=Qt 4 Designer
+Name=Qt Designer
GenericName=Interface Designer
-X-KDE-StartupNotify=true
MimeType=application/x-designer
Icon=/usr/share/pixmaps/designer.png
Terminal=false
diff --git a/abs/core-testing/qt/qt4-linguist.desktop b/abs/core-testing/qt/linguist.desktop
index fee679e..04519bf 100644
--- a/abs/core-testing/qt/qt4-linguist.desktop
+++ b/abs/core-testing/qt/linguist.desktop
@@ -1,9 +1,7 @@
[Desktop Entry]
-Encoding=UTF-8
Exec=/usr/bin/linguist
-Name=Qt 4 Linguist
+Name=Qt Linguist
GenericName=Translation Tool
-X-KDE-StartupNotify=true
MimeType=application/x-linguist
Terminal=false
Type=Application
diff --git a/abs/core-testing/qt/qdoc3.patch b/abs/core-testing/qt/qdoc3.patch
new file mode 100644
index 0000000..38ae735
--- /dev/null
+++ b/abs/core-testing/qt/qdoc3.patch
@@ -0,0 +1,22 @@
+diff -up qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro.qdoc3 qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro
+--- qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro.qdoc3 2009-02-25 15:09:26.000000000 -0600
++++ qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro 2009-03-04 09:30:05.000000000 -0600
+@@ -106,3 +106,7 @@ win32 {
+ QT_WINCONFIG = debug
+ }
+ }
++
++TARGET= qdoc3
++target.path = $$[QT_INSTALL_BINS]
++INSTALLS += target
+diff -up qt-x11-opensource-src-4.5.0/tools/tools.pro.qdoc3 qt-x11-opensource-src-4.5.0/tools/tools.pro
+--- qt-x11-opensource-src-4.5.0/tools/tools.pro.qdoc3 2009-02-25 15:09:27.000000000 -0600
++++ qt-x11-opensource-src-4.5.0/tools/tools.pro 2009-03-04 09:44:18.000000000 -0600
+@@ -13,6 +13,7 @@ no-png {
+ SUBDIRS += designer
+ }
+ SUBDIRS += linguist
++ SUBDIRS += qdoc3
+ wince*: SUBDIRS = qtestlib designer
+ unix:!mac:!embedded:contains(QT_CONFIG, qt3support):SUBDIRS += qtconfig
+ win32:!wince*:!contains(QT_EDITION, OpenSource|Console):SUBDIRS += activeqt
diff --git a/abs/core-testing/qt/qtconfig.desktop b/abs/core-testing/qt/qtconfig.desktop
new file mode 100644
index 0000000..633d921
--- /dev/null
+++ b/abs/core-testing/qt/qtconfig.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Qt Config
+Comment=Configure Qt behavior, styles, fonts
+Exec=/usr/bin/qtconfig
+Icon=/usr/share/pixmaps/qtlogo
+Terminal=false
+Type=Application
+Categories=Qt;Settings;