summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config/timezip.py
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
commitad58e3033f6bb5137b8dcb0e7eca12d50d888402 (patch)
tree9321335a68173bc3e4c1d237c19c8880411fa676 /abs/core/LinHES-config/timezip.py
parent998faf16b1b62493b39aa13b3cb53dfac266ef4c (diff)
parent9709ca528ca5dfbdb6ec6ea283ac6670e8f33b9d (diff)
downloadlinhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.zip
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.gz
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Conflicts: abs/core/tzdata/PKGBUILD
Diffstat (limited to 'abs/core/LinHES-config/timezip.py')
-rwxr-xr-xabs/core/LinHES-config/timezip.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/abs/core/LinHES-config/timezip.py b/abs/core/LinHES-config/timezip.py
index ca20921..4e494be 100755
--- a/abs/core/LinHES-config/timezip.py
+++ b/abs/core/LinHES-config/timezip.py
@@ -106,9 +106,10 @@ def selectvars():
result = cursor.fetchone()
try:
hobbitclient=result[0]
- except TypeError:
+ except:
+ hobbitclient="1"
+ else:
hobbitclient="1"
-
def insertvars():
@@ -184,7 +185,7 @@ def insertvars():
#hobbitclient
cursor.execute("select * from settings where value='HostServiceHobbitclient' and hostname=(%s)",(thishostname))
result = cursor.fetchone()
- if ( tz != ""):
+ if ( hobbitclient != ""):
if (result == None):
cursor.execute("INSERT INTO settings (value,data,hostname) VALUES ('HostServiceHobbitclient',(%s),(%s))",(hobbitclient,thishostname))
print "inserting hobbitcleint"