summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system/firstboot.sh
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-04-15 18:09:52 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-04-15 18:09:52 (GMT)
commitfc98dbe17ad2e565b67a6c5ec715ab2bcca161f0 (patch)
tree9b41479aa679f286ba72c516b8a1996b3851fa63 /abs/core/LinHES-system/firstboot.sh
parentc4b1cc7f705de9b4d539e8bba18170607e2c93f9 (diff)
parentab2b92bf6743790902c68e764b7e28b4aa0a681a (diff)
downloadlinhes_pkgbuild-fc98dbe17ad2e565b67a6c5ec715ab2bcca161f0.zip
linhes_pkgbuild-fc98dbe17ad2e565b67a6c5ec715ab2bcca161f0.tar.gz
linhes_pkgbuild-fc98dbe17ad2e565b67a6c5ec715ab2bcca161f0.tar.bz2
Merge branch 'testing' of git@linhes.org:linhes_pkgbuild into testing
Conflicts: abs/core/LinHES-system/PKGBUILD
Diffstat (limited to 'abs/core/LinHES-system/firstboot.sh')
-rwxr-xr-xabs/core/LinHES-system/firstboot.sh21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/core/LinHES-system/firstboot.sh b/abs/core/LinHES-system/firstboot.sh
index 7e2f603..8e3dc57 100755
--- a/abs/core/LinHES-system/firstboot.sh
+++ b/abs/core/LinHES-system/firstboot.sh
@@ -23,6 +23,26 @@ function try_smolt {
}
+function fix_lirc_socket {
+ . /etc/systemconfig
+
+ # Fix LircSocket in mythtv database
+ SOCKET=`mysql -u mythtv -pmythtv -B --skip-column-names -h "${dbhost}" -D mythconverg -e \
+ "SELECT data FROM settings WHERE value = 'LircSocket' AND hostname = '${hostname}';"`
+ if [ "${SOCKET}" != "/var/run/lirc/lircd" ]; then
+ mysql -u mythtv -pmythtv -B --skip-column-names -h "${dbhost}" -D mythconverg -e \
+ "UPDATE settings SET data = '/var/run/lirc/lircd' WHERE value = 'LircSocket' AND hostname = '${hostname}';"
+ else
+ echo ">>>"
+ echo ">>> ATTENTION! ATTENTION! ATTENTION!"
+ echo ">>> Unable to connect the the MySQL database to make needed"
+ echo ">>> changes to the LIRC socket."
+ echo ">>> LIRC now uses /var/run/lirc/lircd and /dev/lirc is now"
+ echo ">>> obsolete. Update your MythTV settings to reflect this."
+ echo ">>>"
+ fi
+}
+
if [ ! -e /tmp/debug ]
then
@@ -35,6 +55,7 @@ then
fb_status=4
while [ $fb_status != 0 ]
do
+ fix_lirc_socket
try_smolt
if [ $fb_status != 0 ]
then