summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system/misc_status_config.py
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-09-02 01:27:53 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-09-02 01:27:53 (GMT)
commit7e5ce60d93b3f9151df01f1917bc870ed6154fa8 (patch)
treead73249cd6003916dec56059875fa4366d49f0e8 /abs/core/LinHES-system/misc_status_config.py
parent2095e9f3f7795b97a31ef521609e3fc7f7b536a4 (diff)
downloadlinhes_pkgbuild-7e5ce60d93b3f9151df01f1917bc870ed6154fa8.zip
linhes_pkgbuild-7e5ce60d93b3f9151df01f1917bc870ed6154fa8.tar.gz
linhes_pkgbuild-7e5ce60d93b3f9151df01f1917bc870ed6154fa8.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
# By Britney Fransen (5) and others # Via Britney Fransen * origin/testing: LinHES-system: Add scripts for misc status in MythWeb. closes #845. linhes-scripts: tweak myth2mkv. Update version to 0.25-004 dvb-firmware: add xc5000c firmware. change xc5000 modprobe options. closes #844 v4l-dvb: update to snapshot from 20120828. refs #844 LinHES-system: update myth_status.py to work with tuners in error. closes #843 curlftpfs: Initial Inclusion. linhes-scripts: minor changes to myth2mkv mythtv:Bumped to latest fixes. Added ./configure items to close #842. LinHES-config:7.4 rdt 9th anniversary release. Conflicts: abs/core/LinHES-config/LinHES-release abs/core/LinHES-config/PKGBUILD abs/core/LinHES-system/PKGBUILD abs/core/linhes-scripts/PKGBUILD abs/core/linhes-scripts/myth2mkv abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
Diffstat (limited to 'abs/core/LinHES-system/misc_status_config.py')
-rwxr-xr-xabs/core/LinHES-system/misc_status_config.py15
1 files changed, 15 insertions, 0 deletions
diff --git a/abs/core/LinHES-system/misc_status_config.py b/abs/core/LinHES-system/misc_status_config.py
new file mode 100755
index 0000000..0a0ba6c
--- /dev/null
+++ b/abs/core/LinHES-system/misc_status_config.py
@@ -0,0 +1,15 @@
+#!/usr/bin/env python2
+
+# This script will configure the myth db to use the misc_status_info scripts
+
+from socket import gethostname
+from MythTV import MythDB
+mythdb = MythDB()
+localhostname = gethostname()
+
+# mythtv-setup
+if mythdb.settings[localhostname].MiscStatusScript == u'':
+ mythdb.settings[localhostname].MiscStatusScript = u'/usr/LH/bin/misc_status_info.sh'
+ print 'The MythTV database setting MiscStatusScript was updated to /usr/LH/bin/misc_status_info.sh.'
+else:
+ print 'The MythTV database setting MiscStatusScript is already set and will not be updated.'