summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system/tvterm.sh
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/core/LinHES-system/tvterm.sh
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core/LinHES-system/tvterm.sh')
-rwxr-xr-xabs/core/LinHES-system/tvterm.sh25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core/LinHES-system/tvterm.sh b/abs/core/LinHES-system/tvterm.sh
new file mode 100755
index 0000000..dfd116b
--- /dev/null
+++ b/abs/core/LinHES-system/tvterm.sh
@@ -0,0 +1,25 @@
+#!/bin/bash
+#
+# Create a terminal with a font that mostly fills the width of the screen.
+
+width=$(echo $(xdpyinfo | grep dimensions:) | cut -d' ' -f2 | cut -dx -f1)
+
+if [ -z "$width" ] ; then
+ width=1024
+fi
+
+if [ $width -ge 1920 ] ; then
+ fontsize=24
+elif [ $width -ge 1440 ] ; then
+ fontsize=21
+elif [ $width -ge 1280 ] ; then
+ fontsize=18
+elif [ $width -ge 1024 ] ; then
+ fontsize=14
+elif [ $width -ge 800 ] ; then
+ fontsize=11
+elif [ $width -ge 640 ] ; then
+ fontsize=8
+fi
+
+xterm -fa 'DejaVu Sans Mono' -fs $fontsize