summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-31 01:35:17 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-31 01:35:17 (GMT)
commit8b08e5b127670b6d5fa7170477754fc3144cb309 (patch)
treebdfee8440555368ed920069443a2ba4fe595c9c1 /abs/core/LinHES-system
parent6325c32f07e7b2c360283b8f368c8b514993c9c8 (diff)
downloadlinhes_pkgbuild-8b08e5b127670b6d5fa7170477754fc3144cb309.zip
linhes_pkgbuild-8b08e5b127670b6d5fa7170477754fc3144cb309.tar.gz
linhes_pkgbuild-8b08e5b127670b6d5fa7170477754fc3144cb309.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
# By Britney Fransen (4) and others # Via Britney Fransen * origin/testing: dvb-firmware: add xc5000c firmware. change xc5000 modprobe options. closes #844 v4l-dvb: update to snapshot from 20120828. refs #844 LinHES-system: update myth_status.py to work with tuners in error. closes #843 curlftpfs: Initial Inclusion. linhes-scripts: minor changes to myth2mkv mythtv:Bumped to latest fixes. Added ./configure items to close #842. LinHES-config:7.4 rdt 9th anniversary release. Conflicts: abs/core/LinHES-config/LinHES-release abs/core/LinHES-config/PKGBUILD abs/core/LinHES-system/PKGBUILD abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
Diffstat (limited to 'abs/core/LinHES-system')
-rw-r--r--abs/core/LinHES-system/myth_status.py16
1 files changed, 9 insertions, 7 deletions
diff --git a/abs/core/LinHES-system/myth_status.py b/abs/core/LinHES-system/myth_status.py
index 4637b90..b4f4375 100644
--- a/abs/core/LinHES-system/myth_status.py
+++ b/abs/core/LinHES-system/myth_status.py
@@ -60,13 +60,15 @@ for i in a:
type = results[0][0]
hostname = results[0][1]
id = i
- c=be.getCurrentRecording(i)
- if c.title == None:
- current_recording = "Idle"
- else:
- current_recording = "Recording %s" %c.title
- print " Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
-
+ try:
+ c=be.getCurrentRecording(i)
+ if c.title == None:
+ current_recording = "Idle"
+ else:
+ current_recording = "Recording %s" %c.title
+ print " Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
+ except:
+ print " Tuner %s (%s) on %s : %s " %(id, type, hostname, "Tuner Error")
print ""
print "Upcoming Recordings (Next %s scheduled):" %(num_upcoming)