summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-06-17 04:30:17 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-06-17 04:30:17 (GMT)
commit9368d08f072ae32e7984417deb44472293129754 (patch)
tree4a4ba308d0455dac54d15061e89923286176ec47 /abs/core/LinHES-system
parent6d01111d04ddeb6208e75d81be3aadf44f8d7c28 (diff)
downloadlinhes_pkgbuild-9368d08f072ae32e7984417deb44472293129754.zip
linhes_pkgbuild-9368d08f072ae32e7984417deb44472293129754.tar.gz
linhes_pkgbuild-9368d08f072ae32e7984417deb44472293129754.tar.bz2
LinHES-system: mythwelcome-set-alarm.sh: add mythwelcome-set-alarm-user.sh to allow user to run additional cmds
unclutter-toggle.sh: adjust defaults linhes_update2.sh and lh_system_host_update: remove pacman --force option as it isn't supported anymore
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD10
-rw-r--r--abs/core/LinHES-system/lh_system_host_update4
-rw-r--r--abs/core/LinHES-system/linhes_update2.sh2
-rwxr-xr-xabs/core/LinHES-system/mythwelcome-set-alarm.sh11
-rw-r--r--abs/core/LinHES-system/unclutter-toggle.sh5
5 files changed, 22 insertions, 10 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index f0dfa3c..f95e899 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=LinHES-system
-pkgver=8.6.1
+pkgver=8.7.0
pkgrel=1
arch=('x86_64')
install=system.install
@@ -87,7 +87,7 @@ md5sums=('9e941d6c6d4edd56f1a89a7ab566763c'
'76b2637cac0452b3acdbeeb4e8a5474b'
'2ee4c6b06d40f2f6058e480d231f60b2'
'dc3eef2a624754e16805d72bbe488b67'
- '617af86b901538817ebdcaf646248dc5'
+ '44c28873afa1d233f0051b52d5071a29'
'542e670e78d117657f93141e9689f54d'
'8da6a7f1703a002f84e66629e847d8a6'
'bb72ab230c7a71706285bd0f31a4fb1f'
@@ -100,7 +100,7 @@ md5sums=('9e941d6c6d4edd56f1a89a7ab566763c'
'88c9c36430875f9530edb79e11dc770a'
'f421f670a9c74724037f70d1dabcad00'
'eab2d188992b1ac561e0ba968544d7a3'
- '74e17d6f7453c52d56fecaed5c3f6ad5'
+ '5d3c7660510911b718f9839e36320e1c'
'47e093e8cfe4b5b96602358e1f540832'
'4cc3401a94500fad269b25c60d99cc4d'
'727a886a1ba237906f48cda2e4e7844b'
@@ -133,12 +133,12 @@ md5sums=('9e941d6c6d4edd56f1a89a7ab566763c'
'a8bbc553cd784ebed2197b96b60addc8'
'a94fe6d980f4b810f2e2ae5352084b39'
'0d1632ea63d8145c173c6aecf0b007f0'
- 'ff689f2e9572a78d88384b2e5774f579'
+ '09b650eceb0b80bb747c5f7650ae2abc'
'a811c5c01cc127ef403a24c941e03c66'
'4a1fda884dcd7d65fb2690fbdbd92a83'
'29f451783db3220b612e00c29e3ded73'
'7fe42dfc99af42a45440c9c3954c3c19'
- '411b2c22c66833cc8e85021992409f1f'
+ 'cc9627eb979b154aa1e31d33cb61afb2'
'410795ef9039e4c6c0484e706ecfd567'
'eb879fee9603a05d5420d4ce8ed9e450'
'02c810c2f47b7c4495fdacaf54189473'
diff --git a/abs/core/LinHES-system/lh_system_host_update b/abs/core/LinHES-system/lh_system_host_update
index 0a63e0a..0d785eb 100644
--- a/abs/core/LinHES-system/lh_system_host_update
+++ b/abs/core/LinHES-system/lh_system_host_update
@@ -1,6 +1,6 @@
#!/bin/bash
# Process that call this script
-# func update
+# func update
# supplemental web
echo "Starting Update"
@@ -42,7 +42,7 @@ case $Hostupdateplan in
echo ""
echo "Updating ALL packages"
pacman -Sy
- pacman --noconfirm -Su --force
+ pacman --noconfirm -Su
;;
"None")
echo ""
diff --git a/abs/core/LinHES-system/linhes_update2.sh b/abs/core/LinHES-system/linhes_update2.sh
index 6c249d3..aa6bc96 100644
--- a/abs/core/LinHES-system/linhes_update2.sh
+++ b/abs/core/LinHES-system/linhes_update2.sh
@@ -4,7 +4,7 @@
if [[ "$1" = "install" ]]
then
msg_client.py --msg "Updating...|middle" --timeout 600 --tag "Updating"
- sudo pacman -Su --force --noconfirm
+ sudo pacman -Su --noconfirm
msg_client.py --clear --tag "Updating"
msg_client.py --kill
msg_client.py --msg "Updates complete.\nReturning to Main Menu.|middle"
diff --git a/abs/core/LinHES-system/mythwelcome-set-alarm.sh b/abs/core/LinHES-system/mythwelcome-set-alarm.sh
index 7b10372..ebb81ef 100755
--- a/abs/core/LinHES-system/mythwelcome-set-alarm.sh
+++ b/abs/core/LinHES-system/mythwelcome-set-alarm.sh
@@ -21,3 +21,14 @@
echo 0 > /sys/class/rtc/rtc0/wakealarm #this clears your alarm
echo $1 > /sys/class/rtc/rtc0/wakealarm #this writes your alarm
cat /proc/driver/rtc > /var/log/wake_alarm
+
+#allows the user to execute additional commands
+userCmds=/home/mythtv/mythwelcome-set-alarm-user.sh
+if [[ -f "$userCmds" ]]
+then
+ sh $userCmds $1
+else
+ echo "#!/bin/sh" > $userCmds
+ chmod a+x $userCmds
+ chown mythtv:mythtv $userCmds
+fi
diff --git a/abs/core/LinHES-system/unclutter-toggle.sh b/abs/core/LinHES-system/unclutter-toggle.sh
index 9b08a14..b3901ca 100644
--- a/abs/core/LinHES-system/unclutter-toggle.sh
+++ b/abs/core/LinHES-system/unclutter-toggle.sh
@@ -1,7 +1,8 @@
#!/bin/bash
PIDUNC=`pidof unclutter`
-jitter=200
-idle=1
+jitter=50
+idle=10
+# unclutter.cfg allows the user to set idle and jitter to their own preference
. /etc/unclutter.cfg
if [ -n "${PIDUNC}" ];
then