summaryrefslogtreecommitdiffstats
path: root/abs/core/ceton-scripts
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-16 22:50:24 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-16 22:50:24 (GMT)
commitd7b0ad9151942bf042e6761b6671fb72078e42e0 (patch)
treedcf64970a4796cabaef14dea6a65d2a8f29b4b18 /abs/core/ceton-scripts
parent1b716c368383693f2ba72bb9fb36c25e40a1e00a (diff)
downloadlinhes_pkgbuild-d7b0ad9151942bf042e6761b6671fb72078e42e0.zip
linhes_pkgbuild-d7b0ad9151942bf042e6761b6671fb72078e42e0.tar.gz
linhes_pkgbuild-d7b0ad9151942bf042e6761b6671fb72078e42e0.tar.bz2
ceton-scripts:Patched so mythtv is default mysql user.
Diffstat (limited to 'abs/core/ceton-scripts')
-rw-r--r--abs/core/ceton-scripts/PKGBUILD11
-rw-r--r--abs/core/ceton-scripts/ccm.patch13
-rw-r--r--abs/core/ceton-scripts/cqcm.patch13
3 files changed, 34 insertions, 3 deletions
diff --git a/abs/core/ceton-scripts/PKGBUILD b/abs/core/ceton-scripts/PKGBUILD
index 5c7d76b..8bab8c0 100644
--- a/abs/core/ceton-scripts/PKGBUILD
+++ b/abs/core/ceton-scripts/PKGBUILD
@@ -3,17 +3,22 @@
pkgname=ceton-scripts
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="Scripts by Ron Frazier for use with Ceton InfiniTV4 and MythTV 0.24"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://linuxtv.org/"
source=('http://www.ronfrazier.net/mythtv/0.24/downloads/ceton_qam_channelmap.tar.gz'
- 'http://www.ronfrazier.net/mythtv/0.24/downloads/ceton_channelmap.tar.gz')
+ 'http://www.ronfrazier.net/mythtv/0.24/downloads/ceton_channelmap.tar.gz'
+ 'ccm.patch' 'cqcm.patch')
build() {
cd $startdir/src/
+ patch -p0 < ccm.patch
+ patch -p0 < cqcm.patch
mkdir -p $startdir/pkg/usr/bin
install -m 755 *.pl $pkgdir/usr/bin
}
md5sums=('7ef75cb01332ab86d56c348353d59a0e'
- 'ab362902926c01a9b03498cc1aed4d14')
+ 'ab362902926c01a9b03498cc1aed4d14'
+ 'b57b7f04c1c177455b47efc958325ab9'
+ '40af5815f67fdf8070cf8aa041928a3b')
diff --git a/abs/core/ceton-scripts/ccm.patch b/abs/core/ceton-scripts/ccm.patch
new file mode 100644
index 0000000..53ec740
--- /dev/null
+++ b/abs/core/ceton-scripts/ccm.patch
@@ -0,0 +1,13 @@
+--- ceton_channelmap.pl.orig 2011-08-16 22:41:03.000000000 +0000
++++ ceton_channelmap.pl 2011-08-16 22:41:47.000000000 +0000
+@@ -8,8 +8,8 @@
+
+ my $mysql_host = 'localhost';
+ my $mysql_db = 'mythconverg';
+-my $mysql_user = 'root';
+-my $mysql_pw = 'PUT PASSWORD HERE';
++my $mysql_user = 'mythtv';
++my $mysql_pw = 'mythtv';
+
+ -e $wget_path or die "Error: wget does not appear to be in the location specified ($wget_path) . Please configure the \$wget_path variable in this script\n";
+
diff --git a/abs/core/ceton-scripts/cqcm.patch b/abs/core/ceton-scripts/cqcm.patch
new file mode 100644
index 0000000..479ed1f
--- /dev/null
+++ b/abs/core/ceton-scripts/cqcm.patch
@@ -0,0 +1,13 @@
+--- ceton_qam_channelmap.pl.orig 2011-08-16 22:41:13.000000000 +0000
++++ ceton_qam_channelmap.pl 2011-08-16 22:42:37.000000000 +0000
+@@ -11,8 +11,8 @@
+
+ my $mysql_host = 'localhost';
+ my $mysql_db = 'mythconverg';
+-my $mysql_user = 'root';
+-my $mysql_pw = 'PUT PASSWORD HERE';
++my $mysql_user = 'mythtv';
++my $mysql_pw = 'mythtv';
+
+ my $global_modulation = 'qam_256';
+