summaryrefslogtreecommitdiffstats
path: root/abs/core/cpio
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/core/cpio
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/core/cpio')
-rw-r--r--abs/core/cpio/PKGBUILD30
-rw-r--r--abs/core/cpio/cpio-gcc43.patch139
-rw-r--r--abs/core/cpio/cpio.install21
3 files changed, 0 insertions, 190 deletions
diff --git a/abs/core/cpio/PKGBUILD b/abs/core/cpio/PKGBUILD
deleted file mode 100644
index 712fa3d..0000000
--- a/abs/core/cpio/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# $Id: PKGBUILD 76085 2010-04-07 18:00:10Z tpowa $
-# Maintainer: judd <jvinet@zeroflux.org>
-pkgname=cpio
-pkgver=2.11
-pkgrel=2
-pkgdesc="A tool to copy files into or out of a cpio or tar archive"
-arch=('i686' 'x86_64')
-license=('GPL')
-url="http://www.gnu.org/software/cpio"
-depends=('glibc')
-source=(ftp://ftp.gnu.org/gnu/cpio/cpio-${pkgver}.tar.gz)
-install=cpio.install
-md5sums=('1112bb6c45863468b5496ba128792f6c')
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --mandir=/usr/share/man
- make || return 1
-}
-package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
- rm -f ${pkgdir}/usr/bin/mt ${pkgdir}/pkg/usr/share/man/man1/mt.1
- mv ${pkgdir}/usr/bin ${pkgdir}/bin
- rm -rf ${pkgdir}/usr/libexec
- # remove mt manpage it conflicts with mt-st from extra
- rm $pkgdir/usr/share/man/man1/mt.1 || return 1
- # remove infodir
- rm $pkgdir/usr/share/info/dir
-}
diff --git a/abs/core/cpio/cpio-gcc43.patch b/abs/core/cpio/cpio-gcc43.patch
deleted file mode 100644
index 0057b8d..0000000
--- a/abs/core/cpio/cpio-gcc43.patch
+++ /dev/null
@@ -1,139 +0,0 @@
-http://bugs.gentoo.org/198817
-
-from upstream gnulib for "extern inline" changes
-
-diff --git a/lib/argp-fmtstream.h b/lib/argp-fmtstream.h
-index 93fa651..50f1387 100644
---- a/lib/argp-fmtstream.h
-+++ b/lib/argp-fmtstream.h
-@@ -1,5 +1,5 @@
- /* Word-wrapping and line-truncating streams.
-- Copyright (C) 1997, 2006 Free Software Foundation, Inc.
-+ Copyright (C) 1997, 2006-2007 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Written by Miles Bader <miles@gnu.ai.mit.edu>.
-
-@@ -134,6 +134,7 @@ extern ssize_t argp_fmtstream_printf (argp_fmtstream_t __fs,
- const char *__fmt, ...)
- __attribute__ ((__format__ (printf, 2, 3)));
-
-+#if _LIBC || !defined __OPTIMIZE__
- extern int __argp_fmtstream_putc (argp_fmtstream_t __fs, int __ch);
- extern int argp_fmtstream_putc (argp_fmtstream_t __fs, int __ch);
-
-@@ -144,6 +145,7 @@ extern size_t __argp_fmtstream_write (argp_fmtstream_t __fs,
- const char *__str, size_t __len);
- extern size_t argp_fmtstream_write (argp_fmtstream_t __fs,
- const char *__str, size_t __len);
-+#endif
-
- /* Access macros for various bits of state. */
- #define argp_fmtstream_lmargin(__fs) ((__fs)->lmargin)
-@@ -153,6 +155,7 @@ extern size_t argp_fmtstream_write (argp_fmtstream_t __fs,
- #define __argp_fmtstream_rmargin argp_fmtstream_rmargin
- #define __argp_fmtstream_wmargin argp_fmtstream_wmargin
-
-+#if _LIBC || !defined __OPTIMIZE__
- /* Set __FS's left margin to LMARGIN and return the old value. */
- extern size_t argp_fmtstream_set_lmargin (argp_fmtstream_t __fs,
- size_t __lmargin);
-@@ -174,6 +177,7 @@ extern size_t __argp_fmtstream_set_wmargin (argp_fmtstream_t __fs,
- /* Return the column number of the current output point in __FS. */
- extern size_t argp_fmtstream_point (argp_fmtstream_t __fs);
- extern size_t __argp_fmtstream_point (argp_fmtstream_t __fs);
-+#endif
-
- /* Internal routines. */
- extern void _argp_fmtstream_update (argp_fmtstream_t __fs);
-@@ -197,7 +201,28 @@ extern int __argp_fmtstream_ensure (argp_fmtstream_t __fs, size_t __amount);
- #endif
-
- #ifndef ARGP_FS_EI
--#define ARGP_FS_EI extern inline
-+# ifdef __GNUC__
-+ /* GCC 4.3 and above with -std=c99 or -std=gnu99 implements ISO C99
-+ inline semantics, unless -fgnu89-inline is used. It defines a macro
-+ __GNUC_STDC_INLINE__ to indicate this situation or a macro
-+ __GNUC_GNU_INLINE__ to indicate the opposite situation.
-+ GCC 4.2 with -std=c99 or -std=gnu99 implements the GNU C inline
-+ semantics but warns, unless -fgnu89-inline is used:
-+ warning: C99 inline functions are not supported; using GNU89
-+ warning: to disable this warning use -fgnu89-inline or the gnu_inline function attribute
-+ It defines a macro __GNUC_GNU_INLINE__ to indicate this situation. */
-+# if defined __GNUC_STDC_INLINE__
-+# define ARGP_FS_EI inline
-+# elif defined __GNUC_GNU_INLINE__
-+# define ARGP_FS_EI extern inline __attribute__ ((__gnu_inline__))
-+# else
-+# define ARGP_FS_EI extern inline
-+# endif
-+# else
-+ /* With other compilers, assume the ISO C99 meaning of 'inline', if
-+ the compiler supports 'inline' at all. */
-+# define ARGP_FS_EI inline
-+# endif
- #endif
-
- ARGP_FS_EI size_t
-diff --git a/lib/argp.h b/lib/argp.h
-index fb11de6..aa76eb4 100644
---- a/lib/argp.h
-+++ b/lib/argp.h
-@@ -520,9 +520,11 @@ extern void __argp_state_help (const struct argp_state *__restrict __state,
- FILE *__restrict __stream,
- unsigned int __flags);
-
-+#if _LIBC || !defined __USE_EXTERN_INLINES
- /* Possibly output the standard usage message for ARGP to stderr and exit. */
- extern void argp_usage (const struct argp_state *__state);
- extern void __argp_usage (const struct argp_state *__state);
-+#endif
-
- /* If appropriate, print the printf string FMT and following args, preceded
- by the program name and `:', to stderr, and followed by a `Try ... --help'
-@@ -551,6 +553,7 @@ extern void __argp_failure (const struct argp_state *__restrict __state,
- const char *__restrict __fmt, ...)
- __attribute__ ((__format__ (__printf__, 4, 5)));
-
-+#if _LIBC || !defined __USE_EXTERN_INLINES
- /* Returns true if the option OPT is a valid short option. */
- extern int _option_is_short (const struct argp_option *__opt) __THROW;
- extern int __option_is_short (const struct argp_option *__opt) __THROW;
-@@ -559,6 +562,7 @@ extern int __option_is_short (const struct argp_option *__opt) __THROW;
- options array. */
- extern int _option_is_end (const struct argp_option *__opt) __THROW;
- extern int __option_is_end (const struct argp_option *__opt) __THROW;
-+#endif
-
- /* Return the input field for ARGP in the parser corresponding to STATE; used
- by the help routines. */
-@@ -579,7 +583,28 @@ extern void *__argp_input (const struct argp *__restrict __argp,
- # endif
-
- # ifndef ARGP_EI
--# define ARGP_EI extern __inline__
-+# ifdef __GNUC__
-+ /* GCC 4.3 and above with -std=c99 or -std=gnu99 implements ISO C99
-+ inline semantics, unless -fgnu89-inline is used. It defines a macro
-+ __GNUC_STDC_INLINE__ to indicate this situation or a macro
-+ __GNUC_GNU_INLINE__ to indicate the opposite situation.
-+ GCC 4.2 with -std=c99 or -std=gnu99 implements the GNU C inline
-+ semantics but warns, unless -fgnu89-inline is used:
-+ warning: C99 inline functions are not supported; using GNU89
-+ warning: to disable this warning use -fgnu89-inline or the gnu_inline function attribute
-+ It defines a macro __GNUC_GNU_INLINE__ to indicate this situation. */
-+# if defined __GNUC_STDC_INLINE__
-+# define ARGP_EI __inline__
-+# elif defined __GNUC_GNU_INLINE__
-+# define ARGP_EI extern __inline__ __attribute__ ((__gnu_inline__))
-+# else
-+# define ARGP_EI extern __inline__
-+# endif
-+# else
-+ /* With other compilers, assume the ISO C99 meaning of 'inline', if
-+ the compiler supports 'inline' at all. */
-+# define ARGP_EI inline
-+# endif
- # endif
-
- ARGP_EI void
diff --git a/abs/core/cpio/cpio.install b/abs/core/cpio/cpio.install
deleted file mode 100644
index e5502ca..0000000
--- a/abs/core/cpio/cpio.install
+++ /dev/null
@@ -1,21 +0,0 @@
-infodir=/usr/share/info
-filelist=(cpio.info)
-
-post_install() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- usr/bin/install-info $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- usr/bin/install-info --delete $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-