summaryrefslogtreecommitdiffstats
path: root/abs/core/cython/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-12-09 17:18:27 (GMT)
committerCecil <knoppmyth@gmail.com>2011-12-09 17:18:27 (GMT)
commitc034db2c880091379f7e58c2938a9689d78fbaa9 (patch)
tree8a074205a2f3bf6ee7fb5945c53e1a1618d41973 /abs/core/cython/PKGBUILD
parent73b42144585c603fc64e7b1d6a126ceb7c486870 (diff)
parentb0c5755ade92ee5b76a6d56248e64254876bc931 (diff)
downloadlinhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.zip
linhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.tar.gz
linhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/cython/PKGBUILD')
-rw-r--r--abs/core/cython/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/cython/PKGBUILD b/abs/core/cython/PKGBUILD
new file mode 100644
index 0000000..9901e43
--- /dev/null
+++ b/abs/core/cython/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=('cython2')
+pkgbase=cython
+pkgver=0.15.1
+pkgrel=2
+pkgdesc="C-Extensions for Python "
+arch=(i686 x86_64)
+url="http://www.cython.org"
+license=('APACHE')
+makedepends=('python2-distribute')
+source=("http://cython.org/release/Cython-$pkgver.tar.gz")
+md5sums=('171021b3845c9ca8bd6d8185b3cde664')
+
+build() {
+ true
+}
+
+
+package_cython2() {
+ depends=('python2')
+
+ cd $srcdir/Cython-$pkgver
+ python2 setup.py install --root=$pkgdir
+
+ mv $pkgdir/usr/bin/cygdb $pkgdir/usr/bin/cygdb2
+ mv $pkgdir/usr/bin/cython $pkgdir/usr/bin/cython2
+}