summaryrefslogtreecommitdiffstats
path: root/abs/core/fam
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-18 03:32:00 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-18 03:32:00 (GMT)
commit5270456c33afb625f98d28b6f96ff6ee76238a2f (patch)
tree5a14eefc3f2cb5f63493acee6c7267abd11cae1a /abs/core/fam
parent488ec84742ffe827420da262b28be8fb5af94289 (diff)
downloadlinhes_pkgbuild-5270456c33afb625f98d28b6f96ff6ee76238a2f.zip
linhes_pkgbuild-5270456c33afb625f98d28b6f96ff6ee76238a2f.tar.gz
linhes_pkgbuild-5270456c33afb625f98d28b6f96ff6ee76238a2f.tar.bz2
fam: bump 4 portmap/rpcbind dep
Diffstat (limited to 'abs/core/fam')
-rw-r--r--abs/core/fam/PKGBUILD24
-rwxr-xr-xabs/core/fam/fam6
-rw-r--r--abs/core/fam/fam-2.7.0-buildfixes.patch69
-rw-r--r--abs/core/fam/fam-2.7.0-limits.patch11
4 files changed, 94 insertions, 16 deletions
diff --git a/abs/core/fam/PKGBUILD b/abs/core/fam/PKGBUILD
index e7f5e41..3287aef 100644
--- a/abs/core/fam/PKGBUILD
+++ b/abs/core/fam/PKGBUILD
@@ -1,38 +1,36 @@
-# $Id: PKGBUILD 15741 2008-10-18 01:59:29Z allan $
+# $Id: PKGBUILD 42582 2009-06-16 05:21:39Z tpowa $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
pkgname=fam
pkgver=2.7.0
-pkgrel=11
-pkgdesc="File Alteration Monitor - used by KDE, GNOME and others"
+pkgrel=14
+pkgdesc="File Alteration Monitor"
arch=('i686' 'x86_64')
license=('LGPL' 'GPL')
-depends=('portmap')
+depends=('rpcbind' 'gcc-libs' 'bash')
url="http://oss.sgi.com/projects/fam/"
backup=(etc/fam/fam.conf)
options=('!makeflags') # Don't !libtool
source=(ftp://oss.sgi.com/projects/fam/download/stable/${pkgname}-${pkgver}.tar.gz
fam-2.7.0-dnotify.patch
fam-2.7.0-largefiles.patch
- fam-2.7.0-noc++.patch
- fam-2.7.0-gcc43.patch
- include_fam_h.patch
+ fam-2.7.0-limits.patch
+ fam-2.7.0-buildfixes.patch
fam)
md5sums=('1bf3ae6c0c58d3201afc97c6a4834e39'
'073d1763318344635ea316293390205c'
'47b41e0b0498793af004696a096d7da1'
- '0274cd113d3dcb015653b5606c7714ac'
- '13c14778038aa9601a27498448e855e0'
'2638b8ffacb9f03b6e438e08ea7b290a'
- '45b648907ba1c7edec17fb544f1f4a13')
+ 'fc0cabc0ac4f819680401eb3090c29c9'
+ '0b4dd9894ccc03f57787f9dfc0a7bd6f')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
patch -Np1 -i ${srcdir}/fam-2.7.0-dnotify.patch || return 1
patch -Np1 -i ${srcdir}/fam-2.7.0-largefiles.patch || return 1
- patch -Np0 -i ${srcdir}/include_fam_h.patch || return 1
- patch -Np1 -i ${srcdir}/fam-2.7.0-noc++.patch || return 1
- patch -Np1 -i ${srcdir}/fam-2.7.0-gcc43.patch || return 1
+ patch -Np0 -i ${srcdir}/fam-2.7.0-limits.patch || return 1
+ patch -Np1 -i ${srcdir}/fam-2.7.0-buildfixes.patch || return 1
chmod 755 configure || return 1
diff --git a/abs/core/fam/fam b/abs/core/fam/fam
index 3acceff..53dd2a4 100755
--- a/abs/core/fam/fam
+++ b/abs/core/fam/fam
@@ -7,11 +7,11 @@ PID=`pidof -o %PPID /usr/sbin/famd`
case "$1" in
start)
#Check for running portmap, start when not running
- ck_daemon portmap && /etc/rc.d/portmap start
+ ck_daemon rpcbind && /etc/rc.d/rpcbind start
stat_busy "Starting File Alteration Monitor"
- if [ ! -f /var/run/daemons/portmap ]; then
+ if [ ! -f /var/run/daemons/rpcbind ]; then
stat_fail
- echo "ERROR: PORTMAP is not running"
+ echo "ERROR: rpcbind is not running"
exit 1
fi
if [ -z "$PID" ]; then
diff --git a/abs/core/fam/fam-2.7.0-buildfixes.patch b/abs/core/fam/fam-2.7.0-buildfixes.patch
new file mode 100644
index 0000000..abc7888
--- /dev/null
+++ b/abs/core/fam/fam-2.7.0-buildfixes.patch
@@ -0,0 +1,69 @@
+diff -Naur fam-2.7.0-old/include/BTree.h fam-2.7.0/include/BTree.h
+--- fam-2.7.0-old/include/BTree.h 2003-01-20 14:22:30.000000000 +1000
++++ fam-2.7.0/include/BTree.h 2009-06-14 21:21:41.000000000 +1000
+@@ -24,6 +24,7 @@
+ #define BTree_included
+
+ #include "Boolean.h"
++#include <cstdlib>
+
+ // This is an in-core B-Tree implementation.
+ //
+diff -Naur fam-2.7.0-old/lib/Client.c++ fam-2.7.0/lib/Client.c++
+--- fam-2.7.0-old/lib/Client.c++ 2003-01-19 00:18:12.000000000 +1000
++++ fam-2.7.0/lib/Client.c++ 2009-06-14 21:22:33.000000000 +1000
+@@ -34,7 +34,7 @@
+ #include <syslog.h>
+ #include <errno.h>
+
+-#include <iostream.h>
++#include <iostream>
+
+ #include "fam.h"
+ #include "Client.h"
+diff -Naur fam-2.7.0-old/src/DNotify.c++ fam-2.7.0/src/DNotify.c++
+--- fam-2.7.0-old/src/DNotify.c++ 2009-06-14 21:14:34.000000000 +1000
++++ fam-2.7.0/src/DNotify.c++ 2009-06-14 21:23:23.000000000 +1000
+@@ -31,6 +31,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <libgen.h>
++#include <cstdlib>
+
+ #include "DNotify.h"
+
+diff -Naur fam-2.7.0-old/src/IMon.c++ fam-2.7.0/src/IMon.c++
+--- fam-2.7.0-old/src/IMon.c++ 2003-01-19 00:18:12.000000000 +1000
++++ fam-2.7.0/src/IMon.c++ 2009-06-14 21:24:11.000000000 +1000
+@@ -40,7 +40,7 @@
+ #include "Interest.h"
+ #include "Log.h"
+ #include "Scheduler.h"
+-#include "alloc.h"
++#include <memory>
+
+ int IMon::imonfd = -2;
+ IMon::EventHandler IMon::ehandler = NULL;
+diff -Naur fam-2.7.0-old/src/Interest.h fam-2.7.0/src/Interest.h
+--- fam-2.7.0-old/src/Interest.h 2009-06-14 21:14:34.000000000 +1000
++++ fam-2.7.0/src/Interest.h 2009-06-14 21:25:25.000000000 +1000
+@@ -29,6 +29,7 @@
+ #include <netinet/in.h> // for in_addr
+
+ #include "Boolean.h"
++#include <cstdlib>
+
+ class Event;
+ class FileSystem;
+diff -Naur fam-2.7.0-old/src/NFSFileSystem.c++ fam-2.7.0/src/NFSFileSystem.c++
+--- fam-2.7.0-old/src/NFSFileSystem.c++ 2003-01-19 00:18:12.000000000 +1000
++++ fam-2.7.0/src/NFSFileSystem.c++ 2009-06-14 21:26:16.000000000 +1000
+@@ -97,7 +97,7 @@
+
+ attr_cache_timeout = ACREGMAX;
+
+- char * p;
++ const char * p;
+
+ if (strstr(opt, "noac")) {
+ f_noac = true;
diff --git a/abs/core/fam/fam-2.7.0-limits.patch b/abs/core/fam/fam-2.7.0-limits.patch
new file mode 100644
index 0000000..4248957
--- /dev/null
+++ b/abs/core/fam/fam-2.7.0-limits.patch
@@ -0,0 +1,11 @@
+--- include/fam.h.orig 2005-05-25 09:26:38.000000000 +0000
++++ include/fam.h 2005-05-25 09:27:04.000000000 +0000
+@@ -41,7 +41,7 @@
+ *****************************************************************************/
+
+ /* For NAME_MAX - maximum # of chars in a filename */
+-#include "limits.h"
++#include <limits.h>
+
+
+