summaryrefslogtreecommitdiffstats
path: root/abs/core/gdk-pixbuf2/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2019-03-19 20:11:10 (GMT)
committerBritney Fransen <brfransen@gmail.com>2019-03-19 20:11:10 (GMT)
commit73cfb83a5baecfe0529fda59ca57233d8843f783 (patch)
tree2dba2103a6f6e43912fc645ca8b48a85ab500ad2 /abs/core/gdk-pixbuf2/PKGBUILD
parent7b41a9288f5d1332c8136df798bb8ca2465bc21c (diff)
parent448cb8d0708224d78c24ce3615dc7eef44d4689b (diff)
downloadlinhes_pkgbuild-73cfb83a5baecfe0529fda59ca57233d8843f783.zip
linhes_pkgbuild-73cfb83a5baecfe0529fda59ca57233d8843f783.tar.gz
linhes_pkgbuild-73cfb83a5baecfe0529fda59ca57233d8843f783.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/gdk-pixbuf2/PKGBUILD')
-rw-r--r--abs/core/gdk-pixbuf2/PKGBUILD55
1 files changed, 35 insertions, 20 deletions
diff --git a/abs/core/gdk-pixbuf2/PKGBUILD b/abs/core/gdk-pixbuf2/PKGBUILD
index ad535fc..d15d040 100644
--- a/abs/core/gdk-pixbuf2/PKGBUILD
+++ b/abs/core/gdk-pixbuf2/PKGBUILD
@@ -1,33 +1,48 @@
-# $Id$
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=gdk-pixbuf2
-pkgver=2.31.1
-pkgrel=2
+pkgver=2.38.0
+pkgrel=1
pkgdesc="An image loading library"
-arch=('i686' 'x86_64')
-url="http://www.gtk.org/"
-license=('LGPL2.1')
-depends=('glib2' 'libpng' 'libtiff' 'libjpeg' 'libx11' 'jasper')
-makedepends=('gtk-doc' 'gobject-introspection')
+arch=(x86_64)
+url="https://wiki.gnome.org/Projects/GdkPixbuf"
+license=(LGPL2.1)
+depends=(glib2 libpng libtiff libjpeg libx11 jasper shared-mime-info)
+makedepends=(gtk-doc gobject-introspection git docbook-xsl meson)
install=gdk-pixbuf2.install
-source=(http://download.gnome.org/sources/gdk-pixbuf/${pkgver:0:4}/gdk-pixbuf-$pkgver.tar.xz)
-sha256sums=('25a75e3c61dac11e6ff6416ad846951ccafac6486b1c6a1bfb0b213b99db52cd')
+_commit=0b1eab312e77701c20b07fb8e38119009f8b34c3 # tags/2.38.0^0
+source=("git+https://gitlab.gnome.org/GNOME/gdk-pixbuf.git#commit=$_commit"
+ gdk-pixbuf-query-loaders.hook)
+sha256sums=('SKIP'
+ '963afcfacde9fd36031d93c8aa4c94a669ab1dbe9ba0d2cf17599b7d358e54c2')
+
+pkgver() {
+ cd gdk-pixbuf
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd gdk-pixbuf
+}
build() {
- cd gdk-pixbuf-$pkgver
+ arch-meson gdk-pixbuf build \
+ -D jasper=true \
+ -D docs=true \
+ -D installed_tests=false
+ ninja -C build
+}
- ./configure --prefix=/usr \
- --with-x11 \
- --with-libjasper \
- --with-included-loaders=png
- make
+check() {
+ cd build
+ # pixbuf-randomly-modified fails randomly
+ meson test -t 3 || :
}
package() {
- cd gdk-pixbuf-$pkgver
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
}
# vim:set ts=2 sw=2 et: