summaryrefslogtreecommitdiffstats
path: root/abs/core/glibc/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-09-27 17:50:46 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-09-27 17:50:46 (GMT)
commitf8cae565578b1128cb909b0905b7b73b9f2841ea (patch)
tree8f7721b08ac366f8589de1c72dd5028ab0a6ed73 /abs/core/glibc/PKGBUILD
parentb8489b8d155b541a7e9fc33c1d912403ee7de44b (diff)
downloadlinhes_pkgbuild-f8cae565578b1128cb909b0905b7b73b9f2841ea.zip
linhes_pkgbuild-f8cae565578b1128cb909b0905b7b73b9f2841ea.tar.gz
linhes_pkgbuild-f8cae565578b1128cb909b0905b7b73b9f2841ea.tar.bz2
glibc: update to 2.32
Diffstat (limited to 'abs/core/glibc/PKGBUILD')
-rw-r--r--abs/core/glibc/PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/abs/core/glibc/PKGBUILD b/abs/core/glibc/PKGBUILD
index 7cc6d22..aa8e37d 100644
--- a/abs/core/glibc/PKGBUILD
+++ b/abs/core/glibc/PKGBUILD
@@ -6,30 +6,31 @@
pkgbase=glibc
pkgname=(glibc lib32-glibc)
-pkgver=2.31
-pkgrel=5
+pkgver=2.32
+pkgrel=4
arch=(x86_64)
url='https://www.gnu.org/software/libc'
license=(GPL LGPL)
makedepends=(git gd lib32-gcc-libs python)
options=(!strip staticlibs)
-#source=(https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz{,.sig}
-_commit=18fdba553dd9b907e9812b90d2cea593f776058f
-source=(git+https://sourceware.org/git/glibc.git#commit=$_commit
+#_commit=3de512be7ea6053255afed6154db9ee31d4e557a
+#source=(git+https://sourceware.org/git/glibc.git#commit=$_commit
+source=(https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz{,.sig}
locale.gen.txt
locale-gen
lib32-glibc.conf
sdt.h sdt-config.h
- bz20338.patch)
+ bz26534.patch)
validpgpkeys=(7273542B39962DF7B299931416792B4EA25340F8 # Carlos O'Donell
BC7C7372637EC10C57D7AA6579C43DFBF1CF2187) # Siddhesh Poyarekar
-md5sums=('SKIP'
+md5sums=('720c7992861c57cf97d66a2f36d8d1fa'
+ 'SKIP'
'07ac979b6ab5eeb778d55f041529d623'
'476e9113489f93b348b21e144b6a8fcf'
'6e052f1cb693d5d3203f50f9d4e8c33b'
'91fec3b7e75510ae2ac42533aa2e695e'
'680df504c683640b02ed4a805797c0b2'
- '430673eccc78e52c249aa4b0f1786450')
+ 'fc57038c1297c7c11258e8dda1623ec2')
prepare() {
mkdir -p glibc-build lib32-glibc-build
@@ -194,11 +195,15 @@ package_glibc() {
# libraries too. Useful for gdb's catch command.
install -Dm644 "$srcdir/sdt.h" "$pkgdir/usr/include/sys/sdt.h"
install -Dm644 "$srcdir/sdt-config.h" "$pkgdir/usr/include/sys/sdt-config.h"
+
+ # Provided by libxcrypt; keep the old shared library for backwards compatibility
+ rm -f "$pkgdir"/usr/include/crypt.h "$pkgdir"/usr/lib/libcrypt.{a,so}
}
package_lib32-glibc() {
pkgdesc='GNU C Library (32-bit)'
depends=("glibc=$pkgver")
+ options+=('!emptydirs')
cd lib32-glibc-build
@@ -227,4 +232,7 @@ package_lib32-glibc() {
-not -name 'libthread_db-*.so' \
-name '*-*.so' -type f -exec strip $STRIP_SHARED {} + 2> /dev/null || true
fi
+
+ # Provided by lib32-libxcrypt; keep the old shared library for backwards compatibility
+ rm -f "$pkgdir"/usr/lib32/libcrypt.{a,so}
}