summaryrefslogtreecommitdiffstats
path: root/abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-07-21 06:43:24 (GMT)
committerCecil <knoppmyth@gmail.com>2011-07-21 06:43:24 (GMT)
commitb82dab737eaa8d38fa8e3ac3689a16619f9160b4 (patch)
treecd7b882b3f0ba686deb39c1b653d98fafe092100 /abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch
parent9b099f713d930c76cdf81e27a7956ff3c74dc697 (diff)
parent09ec7e57ac7f9907122de23be187b1f05d19a18f (diff)
downloadlinhes_pkgbuild-b82dab737eaa8d38fa8e3ac3689a16619f9160b4.zip
linhes_pkgbuild-b82dab737eaa8d38fa8e3ac3689a16619f9160b4.tar.gz
linhes_pkgbuild-b82dab737eaa8d38fa8e3ac3689a16619f9160b4.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch')
-rw-r--r--abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch b/abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch
new file mode 100644
index 0000000..e2beea8
--- /dev/null
+++ b/abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch
@@ -0,0 +1,26 @@
+diff --git a/include/libc-symbols.h b/include/libc-symbols.h
+index 67e1ca2..5e7cca5 100644
+--- a/include/libc-symbols.h
++++ b/include/libc-symbols.h
+@@ -635,7 +635,7 @@ for linking")
+ # define libc_hidden_proto(name, attrs...) hidden_proto (name, ##attrs)
+ # define libc_hidden_def(name) hidden_def (name)
+ # define libc_hidden_weak(name) hidden_weak (name)
+-# define libc_hidden_nolink(name, version) hidden_nolink (name, libc, version)
++# define libc_hidden_nolink(name, version) hidden_def (name)
+ # define libc_hidden_ver(local, name) hidden_ver (local, name)
+ # define libc_hidden_data_def(name) hidden_data_def (name)
+ # define libc_hidden_data_weak(name) hidden_data_weak (name)
+diff --git a/sunrpc/Makefile b/sunrpc/Makefile
+index 5134ce9..40c73d1 100644
+--- a/sunrpc/Makefile
++++ b/sunrpc/Makefile
+@@ -53,7 +53,7 @@ headers-in-tirpc = $(addprefix rpc/,auth.h auth_unix.h clnt.h pmap_clnt.h \
+ des_crypt.h)
+ headers-not-in-tirpc = $(addprefix rpc/,key_prot.h rpc_des.h) \
+ $(rpcsvc:%=rpcsvc/%) rpcsvc/bootparam.h
+-headers = rpc/netdb.h
++headers = rpc/netdb.h $(headers-in-tirpc) $(headers-not-in-tirpc)
+ install-others = $(inst_sysconfdir)/rpc
+ generated = $(rpcsvc:%.x=rpcsvc/%.h) $(rpcsvc:%.x=x%.c) $(rpcsvc:%.x=x%.stmp) \
+ $(rpcsvc:%.x=rpcsvc/%.stmp) rpcgen