summaryrefslogtreecommitdiffstats
path: root/abs/core/ipw3945-ucode
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/ipw3945-ucode
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/ipw3945-ucode')
-rw-r--r--abs/core/ipw3945-ucode/PKGBUILD22
-rw-r--r--abs/core/ipw3945-ucode/ipw3945-ucode.install18
2 files changed, 40 insertions, 0 deletions
diff --git a/abs/core/ipw3945-ucode/PKGBUILD b/abs/core/ipw3945-ucode/PKGBUILD
new file mode 100644
index 0000000..dbc79ca
--- /dev/null
+++ b/abs/core/ipw3945-ucode/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Giovanni Scafora <linuxmania@gmail.com>
+
+pkgname=ipw3945-ucode
+pkgver=1.14.2
+pkgrel=2
+pkgdesc="Intel Centrino Drivers firmware for IPW3945"
+arch=(i686 x86_64)
+url="http://www.bughost.org/ipw3945"
+license=""
+depends=('udev')
+install=ipw3945-ucode.install
+source=(http://www.bughost.org/ipw3945/ucode/$pkgname-$pkgver.tgz)
+
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ #Install firmware
+ install -D -m 644 ipw3945.ucode $startdir/pkg/lib/firmware/ipw3945.ucode
+ # Install firmware license
+ install -D -m 644 LICENSE.ipw3945-ucode $startdir/pkg/lib/firmware/LICENSE.ipw3945-ucode
+}
+md5sums=('c1c4cc7f993f448e7c05768c012084aa')
diff --git a/abs/core/ipw3945-ucode/ipw3945-ucode.install b/abs/core/ipw3945-ucode/ipw3945-ucode.install
new file mode 100644
index 0000000..9296f8c
--- /dev/null
+++ b/abs/core/ipw3945-ucode/ipw3945-ucode.install
@@ -0,0 +1,18 @@
+# arg 1: the new package version
+post_install() {
+cat << EOF
+IMPORTANT
+==> In order to use this firmware you have to agree to Intel's license located in
+==> /lib/firmware/LICENSE.ipw3945-ucode else please remove this package.
+EOF
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*