summaryrefslogtreecommitdiffstats
path: root/abs/core/ldm
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-06 22:17:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-06 22:17:09 (GMT)
commita2323eff147f149120eba563a4ed739a1ceae856 (patch)
tree2b16cbd534dad499c73ec6a60fe02e15f6177bab /abs/core/ldm
parent89381a83e4a0c7abf27bf69fd4048750af151671 (diff)
downloadlinhes_pkgbuild-a2323eff147f149120eba563a4ed739a1ceae856.zip
linhes_pkgbuild-a2323eff147f149120eba563a4ed739a1ceae856.tar.gz
linhes_pkgbuild-a2323eff147f149120eba563a4ed739a1ceae856.tar.bz2
ldm: used to automount usb devices:
refs #866
Diffstat (limited to 'abs/core/ldm')
-rw-r--r--abs/core/ldm/PKGBUILD30
-rw-r--r--abs/core/ldm/ldm.install9
2 files changed, 39 insertions, 0 deletions
diff --git a/abs/core/ldm/PKGBUILD b/abs/core/ldm/PKGBUILD
new file mode 100644
index 0000000..ba91109
--- /dev/null
+++ b/abs/core/ldm/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Robin Hahling
+pkgname=ldm
+pkgver=0.3
+pkgrel=1
+pkgdesc="A lightweight device mounter"
+arch=('i686' 'x86_64')
+url="https://github.com/LemonBoy/ldm"
+license=('MIT')
+depends=('udev')
+provides=('ldm')
+conflicts=('ldm-git')
+source=(http://github.com/LemonBoy/${pkgname}/tarball/v${pkgver})
+install=ldm.install
+
+build() {
+ cd LemonBoy-${pkgname}-8417f5b
+ # needed before it is fixed in the Makefile
+ export LDFLAGS=""
+ make
+}
+
+package() {
+ cd LemonBoy-${pkgname}-8417f5b
+ make PREFIX="/usr" DESTDIR="${pkgdir}" install
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('3b8d4d7117f5b007ff3311c56c789e98')
diff --git a/abs/core/ldm/ldm.install b/abs/core/ldm/ldm.install
new file mode 100644
index 0000000..b32f1b7
--- /dev/null
+++ b/abs/core/ldm/ldm.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo 'ldm expects a config file at /etc/conf.d/ldm containing your user and group id (uid and gid respectively).'
+ echo 'Just add those two lines into it:'
+ echo 'USER_GID=<output of `id -g` ran from your user>'
+ echo 'USER_UID=<output of `id -u` ran from your user>'
+}
+post_upgrade() {
+ post_install
+}