summaryrefslogtreecommitdiffstats
path: root/abs/core/libxfontcache/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-08 21:38:23 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-08 21:38:23 (GMT)
commit387348a06c19253fa328d8aa9d421328e2aab993 (patch)
treea4b2e5e758781a70166148a07d6087538e649856 /abs/core/libxfontcache/PKGBUILD
parent0254eddd2f14c7eade65cd0179f2b83a21afa329 (diff)
downloadlinhes_pkgbuild-387348a06c19253fa328d8aa9d421328e2aab993.zip
linhes_pkgbuild-387348a06c19253fa328d8aa9d421328e2aab993.tar.gz
linhes_pkgbuild-387348a06c19253fa328d8aa9d421328e2aab993.tar.bz2
libxfontcache: Oops. We needed this afterall.
Diffstat (limited to 'abs/core/libxfontcache/PKGBUILD')
-rw-r--r--abs/core/libxfontcache/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/libxfontcache/PKGBUILD b/abs/core/libxfontcache/PKGBUILD
new file mode 100644
index 0000000..0f01a34
--- /dev/null
+++ b/abs/core/libxfontcache/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 55250 2009-10-12 16:05:23Z andyrtr $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libxfontcache
+pkgver=1.0.5
+pkgrel=2
+pkgdesc="X11 font cache library"
+arch=('i686' 'x86_64')
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libxext' 'fontcacheproto')
+makedepends=('pkgconfig')
+options=('!libtool')
+source=(${url}/releases/individual/lib/libXfontcache-${pkgver}.tar.bz2 LICENSE)
+
+build() {
+ cd ${srcdir}/libXfontcache-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-static \
+ --build=${CHOST} --host=${CHOST}
+ make || return 1
+}
+package() {
+ cd ${srcdir}/libXfontcache-${pkgver}
+ make DESTDIR=${pkgdir} install || return 1
+ install -D -m644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+md5sums=('bbd37768c87f63cf2eb845b2c0f56515'
+ '9738fb66a1a69ce086c461d5bedc7d8f')