summaryrefslogtreecommitdiffstats
path: root/abs/core/lighttpd
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-12-09 17:18:27 (GMT)
committerCecil <knoppmyth@gmail.com>2011-12-09 17:18:27 (GMT)
commitc034db2c880091379f7e58c2938a9689d78fbaa9 (patch)
tree8a074205a2f3bf6ee7fb5945c53e1a1618d41973 /abs/core/lighttpd
parent73b42144585c603fc64e7b1d6a126ceb7c486870 (diff)
parentb0c5755ade92ee5b76a6d56248e64254876bc931 (diff)
downloadlinhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.zip
linhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.tar.gz
linhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/lighttpd')
-rw-r--r--abs/core/lighttpd/PKGBUILD4
-rw-r--r--abs/core/lighttpd/__changelog9
-rw-r--r--abs/core/lighttpd/lighttpd.conf21
3 files changed, 25 insertions, 9 deletions
diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index ba553a2..99d9eac 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lighttpd
pkgver=1.4.28
-pkgrel=3
+pkgrel=4
pkgdesc='A secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -78,5 +78,5 @@ package() {
md5sums=('586eb535d31ac299652495b058dd87c4'
'bd690eee0d9e51857448770a151023b0'
'857e174643fd7761a2f0d8431a679f6c'
- '11fbec7ff7ca1b0d5575445681e8f60e'
+ '1a55e81d5501584fdf00b6fd0196f82f'
'c6e361131000ceec085f40b310ef4a2c')
diff --git a/abs/core/lighttpd/__changelog b/abs/core/lighttpd/__changelog
index 4658cd1..375590d 100644
--- a/abs/core/lighttpd/__changelog
+++ b/abs/core/lighttpd/__changelog
@@ -16,3 +16,12 @@ Added etc/lighttpd/conf.include and etc/lighttpd/html.include to backup array
upgrade to 1.4.28
php-cgi is a depends.
+
+---
+
+added bash and python to cgi list
+ cgi.assign = ( ".pl" => "/usr/bin/perl",
+ ".cgi" => "/usr/bin/perl"
+ ".sh" => "/bin/bash",
+ ".py" => "/usr/bin/python")
+
diff --git a/abs/core/lighttpd/lighttpd.conf b/abs/core/lighttpd/lighttpd.conf
index f437484..9851727 100644
--- a/abs/core/lighttpd/lighttpd.conf
+++ b/abs/core/lighttpd/lighttpd.conf
@@ -14,15 +14,15 @@
server.modules = (
"mod_rewrite",
# "mod_redirect",
-# "mod_alias",
+ "mod_alias",
"mod_access",
# "mod_cml",
# "mod_trigger_b4_dl",
"mod_auth",
-# "mod_status",
+ "mod_status",
"mod_setenv",
"mod_fastcgi",
-# "mod_proxy",
+ "mod_proxy",
# "mod_simple_vhost",
# "mod_evhost",
# "mod_userdir",
@@ -40,7 +40,14 @@ server.modules = (
server.document-root = "/data/srv/httpd/htdocs"
## where to send error-messages to
-server.errorlog = "/var/log/lighttpd/error.log"
+#server.errorlog = "/var/log/lighttpd/error.log"
+#### accesslog module
+#accesslog.filename = "/var/log/lighttpd/access.log"
+
+#send errors to syslog
+server.errorlog-use-syslog = "enable"
+$HTTP["url"] !~ "\.(jpe?g|png|gif|css)" { accesslog.use-syslog = "enable" }
+
# files to check for if .../ is requested
index-file.names = ( "index.php", "index.html",
@@ -116,8 +123,6 @@ mimetype.assign = (
## be nice and keep it at lighttpd
# server.tag = "lighttpd"
-#### accesslog module
-accesslog.filename = "/var/log/lighttpd/access.log"
## deny access the file-extensions
#
@@ -235,7 +240,9 @@ server.groupname = "http"
)
#### CGI module
cgi.assign = ( ".pl" => "/usr/bin/perl",
- ".cgi" => "/usr/bin/perl" )
+ ".cgi" => "/usr/bin/perl",
+ ".sh" => "/bin/bash",
+ ".py" => "/usr/bin/python")
url.rewrite-once = (
"^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",