summaryrefslogtreecommitdiffstats
path: root/abs/core/linhes-scripts/myth2mkv
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-21 23:23:23 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-21 23:23:23 (GMT)
commita8c427b35b9b33fcd176141522732541634ebfd0 (patch)
tree41393fa821ff2049e11d4aa13952ae6ac7c938f6 /abs/core/linhes-scripts/myth2mkv
parent3ce90eb147c39ab18d6360742738225811457392 (diff)
downloadlinhes_pkgbuild-a8c427b35b9b33fcd176141522732541634ebfd0.zip
linhes_pkgbuild-a8c427b35b9b33fcd176141522732541634ebfd0.tar.gz
linhes_pkgbuild-a8c427b35b9b33fcd176141522732541634ebfd0.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
# By Cecil (2) and Michael Hanson (1) # Via Michael Hanson * origin/testing: linhes-scripts: minor changes to myth2mkv mythtv:Bumped to latest fixes. Added ./configure items to close #842. LinHES-config:7.4 rdt 9th anniversary release. Conflicts: abs/core/LinHES-config/LinHES-release abs/core/LinHES-config/PKGBUILD abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
Diffstat (limited to 'abs/core/linhes-scripts/myth2mkv')
-rw-r--r--abs/core/linhes-scripts/myth2mkv7
1 files changed, 5 insertions, 2 deletions
diff --git a/abs/core/linhes-scripts/myth2mkv b/abs/core/linhes-scripts/myth2mkv
index f180b31..447e3c4 100644
--- a/abs/core/linhes-scripts/myth2mkv
+++ b/abs/core/linhes-scripts/myth2mkv
@@ -2,7 +2,7 @@
#
# Convert video to AVC-1 / h264
#
-# version 0.25-002
+# version 0.25-003
#
# Prerequisites:
# - mythtv >= 0.25
@@ -204,10 +204,13 @@ if [[ ${QUALITY} = HQ ]] ; then
if [[ -n ${CROP} ]] ; then
CROP="--crop ${CROP}"
else
- CROP="--crop 0:0:0:0"
+ CROP="--crop 0:0:0:0 --strict-anamorphic"
fi
HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -x b-adapt=2:rc-lookahead=50 -b 5000 -2 -T ${WIDTH} ${HEIGHT} -r ${FPS} --cfr ${CROP} ${DEINT} -a 1 -E copy -s 1"
else
+ if [[ ${CROP} = "--crop 0:0:0:0" ]] ; then
+ CROP="${CROP} --strict-anamorphic"
+ fi
if [[ ${QUALITY} = LQ ]] ; then
HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -b 1250 ${WIDTH} ${HEIGHT} -r ${FPS} --pfr ${CROP} ${DEINT} -a 1 -E lame -B 128 -Q 8 -6 stereo -s 1"
else