summaryrefslogtreecommitdiffstats
path: root/abs/core/myththemes/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-10 23:13:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-10 23:13:08 (GMT)
commit88c1b84963b442a1d39d8193ce72d17e297f006f (patch)
tree707179173751bff29a018a403dbed4923db47985 /abs/core/myththemes/PKGBUILD
parentbf347ccc26e6d65950cea72b1990dbf8c9fe98c1 (diff)
parent7921961814dea89fbf846d06095afd207c8dfd23 (diff)
downloadlinhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.zip
linhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.tar.gz
linhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/myththemes/PKGBUILD')
-rw-r--r--abs/core/myththemes/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/abs/core/myththemes/PKGBUILD b/abs/core/myththemes/PKGBUILD
new file mode 100644
index 0000000..9c71117
--- /dev/null
+++ b/abs/core/myththemes/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 86938 2010-08-06 21:53:33Z ibiru $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=myththemes
+pkgver=0.24
+pkgrel=2
+pkgdesc="Themes for MythTV"
+arch=('any')
+url="http://www.mythtv.org/"
+license=('GPL')
+depends=("mythtv>=${pkgver}")
+source=(`echo ${patches[@]:0}`)
+
+build() {
+ _svntrunk="http://svn.mythtv.org/svn/branches/release-0-24-fixes"
+ _svnmod="${pkgname}"
+
+ # get clean copy from SVN repo
+ if [ -d "${srcdir}/${pkgname}" ]
+ then
+ cd "${srcdir}/${pkgname}"
+ msg "Clean up from previous build..."
+ make distclean
+ msg "Updating from SVN..."
+ svn up
+ else
+ cd "${srcdir}"
+ msg "Checking Out from SVN..."
+ svn co "${_svntrunk}/${_svnmod}"
+ cd "${srcdir}/${pkgname}"
+ fi
+
+ # apply patches
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patchs[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}"
+ make INSTALL_ROOT="${pkgdir}" install || return 1
+}