summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/old/stable-0.21/mythdb-initial/mythdb.install
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/core/mythtv/old/stable-0.21/mythdb-initial/mythdb.install
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core/mythtv/old/stable-0.21/mythdb-initial/mythdb.install')
-rwxr-xr-xabs/core/mythtv/old/stable-0.21/mythdb-initial/mythdb.install31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core/mythtv/old/stable-0.21/mythdb-initial/mythdb.install b/abs/core/mythtv/old/stable-0.21/mythdb-initial/mythdb.install
new file mode 100755
index 0000000..4834c69
--- /dev/null
+++ b/abs/core/mythtv/old/stable-0.21/mythdb-initial/mythdb.install
@@ -0,0 +1,31 @@
+mydate=`date +%m-%d-%y`
+HOST=`hostname`
+post_install() {
+#echo backup the old database
+ mysqldump mythconverg >/data/database/mythconverg.${mydate}.sql
+# echo dropping the old database
+ mysql -u root -e 'drop database mythconverg;'
+ mysql -u root -e 'create database mythconverg;'
+ echo installing the default database
+ if [ $HOST = 'larch5' ]
+ then
+ cp /data/database/mc.sql.initial /data/database/mc.sql.fixed
+ cp /data/database/permissions.sql /data/database/permissions.sql.fixed
+ else
+ sed -e "s/larch5/$HOST/g" /data/database/mc.sql.initial > /data/database/mc.sql.fixed
+ sed -e "s/larch5/$HOST/g" /data/database/permissions.sql > /data/database/permissions.sql.fixed
+
+ fi
+
+ mysql mythconverg < /data/database/mc.sql.fixed 2>/dev/null
+ mysql < /data/database/permissions.sql.fixed 2>/dev/null
+
+ rm /data/database/mc.sql.initial
+}
+post_upgrade() {
+ echo "nothing to do"
+}
+
+op=$1
+shift
+$op $*