summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/old/stable-0.23/mythweb/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
commita88e0a4caaee4269707417416f8e36c754ea6e16 (patch)
treede63f290d0c85422f5c9bb8bfb3e186030f79080 /abs/core/mythtv/old/stable-0.23/mythweb/PKGBUILD
parent9b21e2c89af805f7e2e3014075318587ae479396 (diff)
parent28df92c527607da6a77cbc2ba0f8f62bc6dff548 (diff)
downloadlinhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.zip
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.gz
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/mythtv/old/stable-0.23/mythweb/PKGBUILD')
-rw-r--r--abs/core/mythtv/old/stable-0.23/mythweb/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/abs/core/mythtv/old/stable-0.23/mythweb/PKGBUILD b/abs/core/mythtv/old/stable-0.23/mythweb/PKGBUILD
new file mode 100644
index 0000000..a3b581a
--- /dev/null
+++ b/abs/core/mythtv/old/stable-0.23/mythweb/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=mythweb
+pkgver=0.23
+pkgrel=29
+pkgdesc="Web interface for MythTV's backend"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv>=0.23' 'lighttpd' 'php' 'local-website')
+groups=('mythtv-extras')
+install=mythweb.install
+
+patches=()
+source=('ftp://ftp.knoppmyth.net/R6/sources/mythplugins-0.23-fixes.tar.bz2' `echo${patches[@]:0}`)
+
+md5sums=('590c6e72c72e10d4c7edf72d7fb6b940')
+
+DOCROOT=/data/srv/httpd/htdocs/mythweb
+
+build() {
+
+ cd $startdir/src/mythplugins
+ svn update
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ mkdir -p $startdir/pkg/$DOCROOT/{image_cache,php_sessions}
+
+# cp -r $startdir/src/mythplugins/mythweb/* $startdir/pkg/$DOCROOT
+# cp $startdir/src/mythplugins-$pkgver/mythweb/data/.htaccess $startdir/pkg/$DOCROOT
+ rsync -arp --exclude .svn --delete-excluded $startdir/src/mythplugins/mythweb/* $startdir/pkg/$DOCROOT
+ rm $startdir/pkg/$DOCROOT/README
+ chown -R http:users $startdir/pkg/$DOCROOT
+ chmod g+rw $startdir/pkg/$DOCROOT/{image_cache,php_sessions,data}
+
+}