summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.24/myththemes
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-04 02:46:00 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-04 02:46:00 (GMT)
commit8eb43d3703f505eaf355c4ba79211c30094a2721 (patch)
treecb3dc46624ef1fd8b4c3aaae549b239a7204afbd /abs/core/mythtv/stable-0.24/myththemes
parent5608cdbcece860b46b4cd0f8a563b89c11366226 (diff)
downloadlinhes_pkgbuild-8eb43d3703f505eaf355c4ba79211c30094a2721.zip
linhes_pkgbuild-8eb43d3703f505eaf355c4ba79211c30094a2721.tar.gz
linhes_pkgbuild-8eb43d3703f505eaf355c4ba79211c30094a2721.tar.bz2
mythtv: upgrade the suite cuz it's been a few weeks (mythtv, mythplugins, myththemes, morethemes, mythsmolt)
Diffstat (limited to 'abs/core/mythtv/stable-0.24/myththemes')
-rw-r--r--abs/core/mythtv/stable-0.24/myththemes/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/abs/core/mythtv/stable-0.24/myththemes/PKGBUILD b/abs/core/mythtv/stable-0.24/myththemes/PKGBUILD
new file mode 100644
index 0000000..7c19e5a
--- /dev/null
+++ b/abs/core/mythtv/stable-0.24/myththemes/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 86938 2010-08-06 21:53:33Z ibiru $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=myththemes
+pkgver=0.24
+pkgrel=6
+pkgdesc="Themes for MythTV"
+arch=('any')
+url="http://www.mythtv.org/"
+license=('GPL')
+depends=("mythtv>=${pkgver}")
+source=(`echo ${patches[@]:0}`)
+
+build() {
+ _svntrunk="http://svn.mythtv.org/svn/branches/release-0-24-fixes"
+ _svnmod="${pkgname}"
+
+ # get clean copy from SVN repo
+ if [ -d "${srcdir}/${pkgname}" ]
+ then
+ cd "${srcdir}/${pkgname}"
+ msg "Clean up from previous build..."
+ make distclean
+ msg "Updating from SVN..."
+ svn up
+ else
+ cd "${srcdir}"
+ msg "Checking Out from SVN..."
+ svn co "${_svntrunk}/${_svnmod}"
+ cd "${srcdir}/${pkgname}"
+ fi
+
+ # apply patches
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patchs[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}"
+ make INSTALL_ROOT="${pkgdir}" install || return 1
+}