summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.24
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2010-12-29 09:03:27 (GMT)
committerCecil <knoppmyth@gmail.com>2010-12-29 09:03:27 (GMT)
commite292ab7f897ae23e1516432d92c0b4aa239e097e (patch)
tree9f9c67bd977d9c3a6322f9c2ea41526571118b64 /abs/core/mythtv/stable-0.24
parenteb0b8a2e6a2b8c78266e2e641a468843deee61c3 (diff)
downloadlinhes_pkgbuild-e292ab7f897ae23e1516432d92c0b4aa239e097e.zip
linhes_pkgbuild-e292ab7f897ae23e1516432d92c0b4aa239e097e.tar.gz
linhes_pkgbuild-e292ab7f897ae23e1516432d92c0b4aa239e097e.tar.bz2
mythtv:initial switch from SVN to Git (still have clean up todo).
Diffstat (limited to 'abs/core/mythtv/stable-0.24')
-rwxr-xr-xabs/core/mythtv/stable-0.24/mythtv/PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
index 2fb4000..65fc538 100755
--- a/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=mythtv
-pkgver=0.24
-pkgrel=8
+pkgver=20101229
+pkgrel=1
pkgdesc="A Homebrew PVR project"
arch=('i686' 'x86_64')
url="http://www.mythtv.org/"
@@ -28,10 +28,9 @@ optdepends=('xmltv: to download tv listings')
#replaces=('mythtv-contrib')
#conflicts=('mythtv-contrib')
source=('mythbackend' 'myth.sh' `echo ${patchs[@]:0}` 'mythbackend.lr' 'mythfrontend.lr' 'pretty')
-
+_gitroot="https://github.com/MythTV/mythtv.git"
+_gitname="${pkgname}"
build() {
- _svntrunk="http://svn.mythtv.org/svn/branches/release-0-24-fixes"
- _svnmod="${pkgname}"
# get clean copy from SVN repo
if [ -d "${srcdir}/${pkgname}" ]
@@ -39,12 +38,13 @@ build() {
cd "${srcdir}/${pkgname}"
msg "Clean up previous build..."
make distclean
- msg "Updating from SVN..."
- svn up
+ msg "Updating from GIT..."
+ git pull origin
+ msg "The local files are updated."
else
cd "${srcdir}"
- msg "Checking Out from SVN..."
- svn co "${_svntrunk}/${_svnmod}"
+ msg "Cloning from GIT..."
+ git clone $_gitroot $_gitname
cd "${srcdir}/${pkgname}"
fi