summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.25/mythtv
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-02 22:20:15 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-02 22:20:15 (GMT)
commit7a0af293fd1a81fb643acbb954d319786035e44e (patch)
tree21d4e03a6268bbaee8a3e803f3841bd58c720e26 /abs/core/mythtv/stable-0.25/mythtv
parente851f51157ac00aa3de03f4bb9743c6a7d91bea8 (diff)
downloadlinhes_pkgbuild-7a0af293fd1a81fb643acbb954d319786035e44e.zip
linhes_pkgbuild-7a0af293fd1a81fb643acbb954d319786035e44e.tar.gz
linhes_pkgbuild-7a0af293fd1a81fb643acbb954d319786035e44e.tar.bz2
mythtv: applied mythweb and php bindings patch to allow mythweb to work with php 5.4
refs #861 closes #861
Diffstat (limited to 'abs/core/mythtv/stable-0.25/mythtv')
-rw-r--r--abs/core/mythtv/stable-0.25/mythtv/MythBase.php.patch19
-rw-r--r--abs/core/mythtv/stable-0.25/mythtv/PKGBUILD4
2 files changed, 22 insertions, 1 deletions
diff --git a/abs/core/mythtv/stable-0.25/mythtv/MythBase.php.patch b/abs/core/mythtv/stable-0.25/mythtv/MythBase.php.patch
new file mode 100644
index 0000000..ff1f4b6
--- /dev/null
+++ b/abs/core/mythtv/stable-0.25/mythtv/MythBase.php.patch
@@ -0,0 +1,19 @@
+*** a/mythtv/bindings/php/MythBase.php.old 2011-04-03 06:05:31.000000000 -0500
+--- b/mythtv/bindings/php/MythBase.php 2012-03-27 05:05:16.000000000 -0500
+***************
+*** 51,57 ****
+
+ public function __destruct() {
+ if (!is_null($this->cacheKey))
+! Cache::setObject($this->cacheKey, &$this, $this->cacheLifetime);
+ $this->cacheKey = null;
+ }
+
+--- 51,57 ----
+
+ public function __destruct() {
+ if (!is_null($this->cacheKey))
+! Cache::setObject($this->cacheKey, $this, $this->cacheLifetime);
+ $this->cacheKey = null;
+ }
+
diff --git a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
index 50f24c1..63f8b90 100644
--- a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
@@ -61,7 +61,8 @@ groups=('pvr')
#options=(!strip)
#MAKEFLAGS="-j6"
install='mythtv.install'
-patchs=('myth_settings.patch')
+#http://code.mythtv.org/trac/ticket/10504
+patchs=('myth_settings.patch' MythBase.php.patch )
optdepends=('xmltv: to download tv listings')
replaces=('mythvideo' 'myththemes')
conflicts=('mythvideo' 'myththemes')
@@ -143,6 +144,7 @@ package() {
md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
'2babd4b8e146a7538d18dcd55695b0be'
'322f48528b350f0e6aebfff6eab4c4ee'
+ '9ec33d6956464283636c1f9a781dd4fd'
'f735805a80b0d1180dee01f9df1b7004'
'f407d6af23e74a49540755420f84fa58'
'5469d9921b726db750b991c87d226158')