summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2012-04-26 21:37:21 (GMT)
committerCecil <knoppmyth@gmail.com>2012-04-26 21:37:21 (GMT)
commitc7112b961322bf9c20282e3bbfb95b2ccf3fa97f (patch)
treeda4450d043b175a7aebb3a93c858b294995b765e /abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
parentf2394fa3f2984a3a4e74a19b2596f279ec3517ba (diff)
parentc8fc2fc2156fdeb0e9a54e7be48c8f02fdff848e (diff)
downloadlinhes_pkgbuild-c7112b961322bf9c20282e3bbfb95b2ccf3fa97f.zip
linhes_pkgbuild-c7112b961322bf9c20282e3bbfb95b2ccf3fa97f.tar.gz
linhes_pkgbuild-c7112b961322bf9c20282e3bbfb95b2ccf3fa97f.tar.bz2
Merge branch 'testing' of git@linhes.org:linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/mythtv/stable-0.25/mythweb/PKGBUILD')
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/PKGBUILD33
1 files changed, 25 insertions, 8 deletions
diff --git a/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD b/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
index cab8fbd..f78c224 100644
--- a/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
+++ b/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
@@ -1,24 +1,41 @@
pkgname=mythweb
-pkgver=0.24
-pkgrel=16
-pkgdesc="Web interface for MythTV's backend"
+pkgver=0.25
+pkgrel=1
+
+commit_hash=`cat ../git_src/git_hash_web`
+
+pkgdesc="Web interface for MythTV's backend, $commit_hash"
url="http://www.mythtv.org"
license="GPL"
arch=('i686' 'x86_64')
-depends=('mythtv>=0.24' 'lighttpd' 'php' 'local-website')
+depends=('mythtv>=0.25' 'lighttpd' 'php' 'local-website')
groups=('mythtv-extras')
patches=()
-source=('ftp://ftp.knoppmyth.net/R6/sources/mythweb-0.24-fixes.tar.bz2' `echo ${patches[@]:0}`)
+source=(`echo ${patches[@]:0}`)
DOCROOT=/data/srv/httpd/htdocs/mythweb
-_gitroot="https://github.com/mythtv/mythweb.git"
-_gitname="${pkgname}"
build() {
+ if [ -e ${srcdir}/mythweb ]
+ then
+ rm -rf ${srcdir}/mythweb
+ fi
+
+ cd ${startdir}
+ msg "copy in myth web src"
+ cp -rp ../git_src/mythweb $srcdir
+ cd ${srcdir}/${pkgbase}
+
+
+
+ msg "The local files are updated."
+
+
cd $startdir/src/mythweb
- git pull
+
+
echo "--------------------------applying patches----------------------------------------------------"
for i in `echo ${patches[@]:0} `