summaryrefslogtreecommitdiffstats
path: root/abs/core/netcfg/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-03 23:14:05 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-03 23:14:05 (GMT)
commit998faf16b1b62493b39aa13b3cb53dfac266ef4c (patch)
treee39f222ebd2e5ca78211045d1d12ccc02f8c5516 /abs/core/netcfg/PKGBUILD
parent085e16d501ac72951e7455385cc8af7e90fa02cb (diff)
parenta9c47f145393b31d7f656b14a2952ab6fc6fec58 (diff)
downloadlinhes_pkgbuild-998faf16b1b62493b39aa13b3cb53dfac266ef4c.zip
linhes_pkgbuild-998faf16b1b62493b39aa13b3cb53dfac266ef4c.tar.gz
linhes_pkgbuild-998faf16b1b62493b39aa13b3cb53dfac266ef4c.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/netcfg/PKGBUILD')
-rw-r--r--abs/core/netcfg/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/netcfg/PKGBUILD b/abs/core/netcfg/PKGBUILD
new file mode 100644
index 0000000..7e7ea7b
--- /dev/null
+++ b/abs/core/netcfg/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 126281 2011-06-04 04:21:49Z eric $
+# Maintainer: James Rayner <james@archlinux.org>
+
+pkgname=netcfg
+pkgver=2.5.5
+pkgrel=1
+pkgdesc="Network configuration and profile scripts"
+url="http://archlinux.org"
+license=("BSD")
+backup=(etc/iftab)
+depends=(wireless_tools coreutils "wpa_supplicant>=0.6.8" net-tools "dhcpcd>=4.0" "iproute2")
+optdepends=('dialog: Required for menu based profile selector'
+ 'wpa_actiond: Required for automatic wireless connection with rc.d/net-auto-wireless'
+ 'ifplugd: Required for automatic wired connection with rc.d/net-auto-wired')
+source=(ftp://ftp.archlinux.org/other/netcfg/netcfg-${pkgver}.tar.gz)
+arch=(any)
+md5sums=('6e98bae291eb206d92f9a92bbab8fe80')
+
+package() {
+ cd "$srcdir/netcfg-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/netcfg/LICENSE"
+ ln -s /usr/lib/network/connections/wireless "$pkgdir/usr/lib/network/connections/wireless-dbus"
+ ln -s /usr/bin/netcfg2 "$pkgdir/usr/bin/netcfg"
+}
+