summaryrefslogtreecommitdiffstats
path: root/abs/core/nss-mdns/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2012-04-24 01:42:16 (GMT)
committerBritney Fransen <brfransen@gmail.com>2012-04-24 01:42:16 (GMT)
commitf2a0080df441e3d9e5f054fdf5c9b48abd218879 (patch)
tree21cb185f548833b66dd1dd53dce98aa1916bdbd5 /abs/core/nss-mdns/PKGBUILD
parent51665a2b73e708c35d1f4e523f0ecf22eb544597 (diff)
parent92e482361cd083f3a38ae0f90acd65de33c7b01f (diff)
downloadlinhes_pkgbuild-f2a0080df441e3d9e5f054fdf5c9b48abd218879.zip
linhes_pkgbuild-f2a0080df441e3d9e5f054fdf5c9b48abd218879.tar.gz
linhes_pkgbuild-f2a0080df441e3d9e5f054fdf5c9b48abd218879.tar.bz2
Merge branch 'testing' of linhes.org:linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/nss-mdns/PKGBUILD')
-rw-r--r--abs/core/nss-mdns/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/core/nss-mdns/PKGBUILD b/abs/core/nss-mdns/PKGBUILD
new file mode 100644
index 0000000..643dac8
--- /dev/null
+++ b/abs/core/nss-mdns/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 124100 2011-05-16 15:17:50Z andrea $
+# Maintainer:
+# Contributor: Travis Willard <travis@archlinux.org>
+
+pkgname=nss-mdns
+pkgver=0.10
+pkgrel=3
+pkgdesc="glibc plugin providing host name resolution via mDNS"
+arch=('i686' 'x86_64')
+url="http://0pointer.de/lennart/projects/nss-mdns/"
+license=('LGPL')
+depends=('glibc')
+makedepends=('pkgconfig')
+backup=('etc/mdns.allow')
+install=nss-mdns.install
+source=("http://0pointer.de/lennart/projects/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'mdns.allow')
+md5sums=('03938f17646efbb50aa70ba5f99f51d7'
+ '904abb492fb1f56722826c0c3a997bf0')
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ ./configure --prefix=/ \
+ --disable-lynx \
+ --enable-avahi
+ make
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}"/mdns.allow "${pkgdir}"/etc/mdns.allow
+}
+